Assassin's Creed Valhalla

Is there something I can do through the .ini file or do you have to make updates to the .dll?

No idea if you can see what the game is doing with memory but the game has a serious issue with virtual memory on my 3800x, 32 GB, 2080 Ti machine.
Spent over 30 hours playing the game where it turned into a <5 fps slideshow after 2 hours in any populated area.
The only two common factors of it happening were NPCs + time spent. And I tried everything to fix it. In the end however it seems that manually setting a page file size in Windows fixed it. Been a long time since I’ve had to do such a fix to a game. Would be interesting to know what on earth it’s doing to cause this…

Yeah some games don’t take well to a non-existent or very small page-file even if it should be using RAM, Windows itself is also a bit mixed as to how it behaves as it will attempt to page without one set so that’s part of the issue too.

Commit charge and size a bit after boot should show how much is paged and that used to be a good way to determine minimum size but later OS versions does a good job with automatic and expanding as needed.
(Usually a few hundred MB at most but then games like these will just not work unless there’s more.)

I use a fixed 4096 size (4 GB) because might as well but some games leak extensively so given time they’d run out eventually.

Clearing standby memory can also help but the Windows 10 OS builds Redstone 4 or 5 I think and newer should be better at releasing cache memory as required core issue here where it was held forever was fixed a while back though it can still be a bit slow at releasing this memory until cleared manually.
(EmptyStandbyList.exe I think is what the software I use for this is called.)

Final Fantasy XV’s another example you can use the task manager and observe how it just hits the page memory frequently. :slight_smile:

EDIT: It’s been a few years since I had a game outright crash from having a too low page size or attempting to use none even with plenty of actual RAM so at least that’s improved.
(Same with the audio issue in some games crashing above 48000 frequencies although that is often already above the 44100 sample size or lower used by most games.)

EDIT:

Something like that, now I’m curious as to how much would be used letting the game go for an hour or two while I’m fiddling with the settlement or something letting it build up a little bit.

I don’t think SpecialK affects this much but I am using the newest D3D12 .dll from that pinned topic as a replacement since it has some additional things although nothing that is outright required. :slight_smile:

Hi can any one help me please? i am trying to use special K linked at the top with valhalla but i keep getting either crash to desktop before it gets to the menu or a black screen and freeze. I know its no third party software causing the issue as i did a fresh install of windows and still same problem. It works fine with zero dawn. Thanks in advance.

Read the first sentence in this post.

You can also use the test version here:

D3D12 Missing Features - Development - Special K Discussion (differentk.fyi)

I am using the pre configured standalone release keeps crashing, I also just tried the test version and exact same issue. Thanks

Disable overlays like RTSS

@Kaldaien, brother…long time admirer of your work from the Tales series, Dragon Quest, etc.

I’ve downloaded the standalone for this game and it does wonders, kudos, but I have a dilemma. I got a LG Oled C8 and I just have a 6850k w/ a 1080ti, on the NV panel, I’ve set it @4k res but when I play, in-game its set to 1080p since I just play 60fps.

I’m having trouble enabling HDR on my tv, is there any tips u can share?? I read several articles saying enabling HDR via Windows but that is not true HDR and its still in the SDR color range, I believe. The only time I see my tv switch on HDR automatically was when I was playing @4k Fullscreen mode but my sytem can’t handle a good fps when its set to that…

I just now have it at 1080p, no limit (fps), borderless, when I switch to HDR via in game, nothing happens after confirmation, WIN HDR is OFF…

You might need to set your desktop resolution to 1080p.

This game uses the modern form of HDR, so that means it needs HDR turned on in the desktop.

You could try the latest D3D12 compatible test build of Special K, its overlay can tell you whether the game’s HDR or not.

In some cases the game doesn’t fully engage HDR until you open the display config menu after starting it.

Thanks for replying to me.
So what’s the difference of setting the in-game resolution to 1080p vs. setting it on NV panel??

So HDR needs to be ON in Windows then set On in-game to make it work…??
It seems that’s the only implementation of HDR for this game as of right now, I’m also running this Borderless, which you suggested since I’m using the standalone Special K??
On the ini file of the standalone, can I set the TargetFPS to no limit? If so, how do I do that??

Setting the desktop resolution changes the system-wide resolution, changing the in-game setting will stretch an image to fill the desktop. Usually there’s not a huge difference, but the game could be programmed to only recognize HDR when the input/output resolution is identical.

Use this and save yourself a lot of time:

dxgi.7z (differentk.fyi)

Just open the control panel and change the framerate limiter in-game. You won’t have to guess what impact it’s having on performance or be mislead by the inaccurate in-game framerate counter / imprecise RTSS graph.

The game was updated. :slight_smile:

EDIT: Where’s that changelog.

EDIT:
[URL]Assassin's Creed Valhalla - Title Update 1.0.4 | Ubisoft Discussion Forums

EDIT: Well…that could have gone worse.
And better.

EDIT: There I mostly resolved the worst of it, kept the Odin Sight emote Ubi threw in too because why not.

Hmm fixing a memory leak and VRAM leak on alt-tab. Good.
Wonder if the game remembers your helmet selection yet. Minor annoyance though.

Is there a way to turn off the GUI in the latest version? For some reason, Valhalla stutters way more with overlays from SpecialK/ReShade/etc.

I’ve been looking into that. I know why the stuttering happens, but not how to fix it.

I had to break my overlay and let D3D12 render while parts of the overlay are still in use.

There’s something weird about the engine’s handling of high framerates that I haven’t figured out (perhaps related to the temporal reconstruction anti-aliasing).

ReShade and other overlays that handle resource barriers the correct way are going to cause performance degradation.

dxgi.7z (7.6 MB)
dxgi_noflicker.7z (7.6 MB)

The first version of SK won’t cause the degradation, but the overlay is going to flicker (if not outright disappear) if framerate goes above refresh rate. All the more reason to use SK’s framerate limiter and set it as strictly as possible (99% CPU in Advanced settings, and Latency Waitable in SwapChain settings)

hey download is extremely slow, is it just me?
hhhm the version above causes issues with HDR. Is this expected? @Kaldaien

Probably…

Use that version instead :slight_smile: I fixed a lot of stuff in addition to that milestone Control D3D12 HDR support.

1 Like

That one still flickers for me. I tried the dxgi_noflicker version but that runs much slower (as in, 40ish FPS instead of 60, with the GPU usage also much lower than normal).

Edit: Nevermind, the flickering lighting and stuff was being caused by running NVCP sharpening.

The new SK version works well like the previous version you posted with the flickering, though I didn’t get any flickering then (and not sure whether that means GUI flickering or actual rasterized/rendered graphical flickering.

Why did Resetera ban you? :frowning:

Also, the new patch crashes the game with your special k files now. (I haven’t updated to your latest files yet) but was curious if u knew why? Removing your files and the crashing goes away

I said something insensitive about cows, apparently. I kid you not. There was a discussion about milk alternatives. Who the hell knows what’s up with ResetEra, weirdest forum I’ve ever see.


Use this version, it’s been verified to work together with ReShade, Ansel, RTSS, the Steam Overlay and Discord:

dxgi.7z (7.6 MB)

I believe I am approaching near release-quality D3D12 support, but it may be another week or so of nightly updates before things settle down.

2 Likes

Nice to see it getting closer to release after what sounds like a lot of weird problems with the D3D12 support due to third party software and a lot of other functionality.

Seems like it’s getting pretty good but yeah there’s probably other stuff and who knows what might come up once it’s released.