Assassin's Creed Valhalla

Thought Vulkan had various presentation modes (The “VSync” support and modes of handling it.) and settings for pre-rendered frames and back buffers too but beyond that I suppose you’d go into the actual swap chain and deeper settings or utilizing either global extensions or having to go by what NVIDIA, AMD, Intel and I think also Google have but some of these might not work on other vendors or even when added as global instruction it drags on for seeing it supported in newer drivers until mandatory whenever a new main Vulkan SDK and version rolls out and the requirements update for what this needs to be certified and validated for.

Takes a while though, Vulkan 1.2.x is still supported and updated with AMD and NVIDIA around 1.2.140.x and various extensions supported or missing still.
(And some wonky driver behavior or misreported support and all that too, sigh.)

EDIT: Hooking into that and manipulating it directly though I’m not so sure on, guessing you’d have the D3D and DXGI platform for Windows DirectX 12 as a possible advantage here for that API comparably.

EDIT: Though I go back and forth reading Vulkan SDK notes, driver changelogs and such info and then lovely lengthy in-depth reports and colorful commentary from Proton and DXVK’s project pages on Github on the nature of the problem with video game ports and mysterious issues and errors that somehow should not exist but continues to do so even years later.

Well that’s a bit of a separate topic from the game here, I have a lot to try and pick up and learn still or at least good as I can which for how complex some of these subjects are is not easy. :slight_smile:

1 Like

I think I might be dumb, I’ve been trying to get the standalone version to work from the OP, but everytime I load up the game now I get either a black screen when starting, or occassionally the game will load up until the point where it tells me about autosaves, but never to the main menu.

When it does get to the auto save part, none of the opening videos have sound, which is weird.

As soon as I uninstall, everything works again without an issue.

Sounds like you have some bizarre third-party software that’s not compliant with stuff SK uses.

You’ll have to track down the software.

1 Like

Fixed it, looks like it was due to global injection being on, as it was auto running at startup on my PC.

So I agree with my earlier statement, I was being dumb! :slight_smile:

… okay.

Probably by the end of this week, the test version in this thread will become the officially released version. I have a bit of documentation to re-write and can’t find any solid distraction free time to do that :-\

I really need more patrons and a hired secretary, lol.

Hey Kal, I have for you the following question: how to get the best results with your magic tool at 30 fps? (console experience) I care about the lowest possible input lag (latency) and best frame pacing :wink:

For example, the following values shouldn’t ​​be lower?

PreRenderLimit=7
BackBufferCount=6

Thanks in advance for any advice from you :slight_smile:

Assuming you’re not using a waitable swapchain, you want those to be lower… definitely.

With a waitable swapchain, however, the latency regulates itself. Every couple of frames, the length of the render queue is cut down by 1 frame, so unless you’re stuttering really bad, latency’s about 1-2 frames max.

You benefit from having more backbuffers because for every 3 backbuffers it allows you to render 2x your refresh rate without VSYNC penalties. For whatever reason, NVIDIA’s drivers work best when you’ve got enough backbuffers to draw way faster than your refresh rate, whether you actually draw that fast or not.


Also, for D3D12 games, many developers don’t know this, but you’re expected to have 2 backbuffers per- command queue.

Most of these games ship with only 1 backbuffer per-command queue. So take whatever the game requested, assume the developer never read NVIDIA’s best practices guidelines, and double it. When it works, that fixes a ton of performance problems in D3D12.

2 Likes

I’ve downloaded and extracted the dll and ini file into the game folder. I think It’s working because Vsync is enabled in the benchmark, but the SK overlay is not showing when I use shift+control+backspace. I know It’s there because the mouse arrow shows up in the upper left corner and I can’t use the main menu buttons. The Ubisoft Connect overlay is also disabled when starting the game with SK.
I’ve also disabled fullscreen optimizations if that matters. Game is running in borderless and vsync enabled in both game and nvidia panel.

Any ideas?

SK can only render in DX11 mode. Are you perhaps running the game in DX12?

The game supports only dx12. No way to run it in dx11 that I know of.

SK’s overlay doesn’t work for Dx12 games. SK is used for improved frame-pacing in AC:V

Well that explains it. I get microstutters when using it though. Very noticable when paning the camera sideways. Playing without it, the stutters are gone. Both in borderless and fullscreen.

It used to be the other way around with Origin and Odyssey.

Maybe you’ve changed a setting on the driver level (GPU control panel) that’s conflicting?

That is a possibility, but what could it be? I’ve changed a lot of settings.

Try this version:

dxgi.7z (7.6 MB)

I changed the waitable swapchain behavior. It was too aggressively trying to get rid of input latency for this game.

3 Likes

That helped, but I can still see microstutters when paning the camera. I’m very sensitive to it, always has been since the 90’s playing on crt monitors. So I know they’re there.

Whatever you did reduced the stutters though.

I will play without it for now. Still running around in Norway and the game is buttery smooth at 60 fps. Everything on highest settings except motion blur and depth of field turned off.

8700k @ 5.1ghz
4000mhz 17-17-17-32 memory
3080 Strix OC.

Ah, that’s a shame. There are things that can be done to tune Special K’s framerate limiter, but the process works best when SK’s in-game UI can actually be used to make the adjustments in real-time.

I know there should be some combination of settings that would work for you, but lack of UI support in D3D12 is unfortunately a big setback here :frowning:

Tuning the framerate limiter settings perhaps but yeah unless SpecialK periodically re-reads the ini file you’d have to exit and set new values.

Possibly macro and a key bind to re-read the file or how to say, kinda like loading a preset I suppose actually possible using that functionality to directly set a config value. :slight_smile:

Think there’s a example macro now for the swap chain and resetting something in regards to that for if you alt-tab frequently or after a few hours of the game running if it starts acting choppy. :slight_smile:

Newer NVIDIA drivers should fix a few things too seems performance is under delivering on AMD Ryzen CPU systems for some reason so that can explain stuttering but in this case it’s a Intel 8000 series and the game(s) from Ubisoft are also kinda RAM bound but a good profile at 3200 - 3600 or higher and you mitigate the worst of it. :slight_smile:

EDIT:

And then a bit more about what further NVIDIA drivers or driver branches can give.
The game itself could do with a patch or several too but how much Ubisoft will optimize well we’ll just have to see.

EDIT: All the avatars and the forum decided to use a dog one for the media embedding. Must be from the opening post or something for how it gets that. :smiley:

After waiting for updates for a long time on the various public places you uploaded updates to (Steam, Github)… it’s nice to see updates are still being made though kinda a clusterfuck to find my way here to this place.

Anyways, I thought I’d give this a shot with Assassin’s Creed Odyssey and Origins and it seems to work fine with both games, which is nice since v0.10.3 and older weren’t working. I dunno if this version messes with the asset streaming/scheduling stuff that was causing performance issues when the games are installed to an SSD though, since I have the games installed to a HDD and don’t experience that issue as a result (at least at 60FPS).


I also tried this version with Monster Hunter World but the game outright refuses to open.

With the SKIF UI program that the Download button at the top of this website downloads, Monster Hunter World will almost reach the Main Menu before it crashes out. Not sure what version is suggested for that game or if it’s even supported anymore by you (considering your past history with trying to support the game it wouldn’t surprise me if you aren’t working on compatibility with that game anymore/at the moment). the SKIF download was also incompatible with the Assassin Creed games.

Really? It should be easier than ever to find Special K now :slight_smile:

It’s just special-k.infowiki.special-k.info , gitlab.special-k.info , sk-data.special-k.info

The one place you won’t find anything Special K related is Steam, @#$% Steam :stuck_out_tongue: