Games with broken HDR

List is accurate as of: 0.11.1.0 - as new SK versions release the games in this list will be re-tested and removed if confirmed working. Additionally, more games may be added as they are released/bugs are discovered.

Games that were once on the list but are now confirmed working will be in the comments section.

Game Status
ADR1FT HDR works for the most part but if you move the character and look in certain directions the HDR will disengage and then re-engage when you look back.
Assassin’s Creed Syndicate Requires delayed injection to prevent crashing.
Batman: Arkham Knight Crashes and visual glitches when not crashing
Call of Duty: Ghosts HDR causes game to crash right after loading into campaign.
Call of Duty: Infinite Warfare HDR causes game to crash right after loading into campaign.
Metro Redux Missing models with HDR enabled making the game unplayable.
Red Faction: Armageddon (?)
Skyrim: Special Edition Screen burn in effect on parts of the UI
Splinter Cell Blacklist Black screen in logos
Strike Suit Zero: Directors Cut HDR sliders don’t do anything ingame
Sunset Overdrive HDR works in menus but as soon as you load in and the character punches the screen the HDR will flicker on/off rapidly.
2 Likes

I assume your first course of action when testing this stuff was to test different combinations of remastering?

10- and 11-bit remastering (on by default) may cause issues like you’ve mentioned in Metro Redux

8-bit remastering (disabled by default) breaks most games, but there are a select few where it’s actually needed for the game to draw anything other than its UI.

Just tried enabling 8-bit remastering. Metro still suffers from the same issue. I also tried turning off 10 and 12 bit separately but no change. It did however fix the flickering on Saints Row Gat Out of Hell so I’ll retest some games and edit the list. Thanks for the help.

Were there any games you tested that did work? :slight_smile: This is a lot to process.

When this happens, it’s usually because of a DPI scaling bug in Unreal Engine 4. You can try working around it by changing the game’s settings to Borderless Fullscreen before turning on HDR with Special K.

That fix worked for the Batman games and a few other Unreal 3 games but for some reason not Soul Suspect or Red Faction Armageddon. Soul Suspect is Unreal 3 and I’m pretty sure Red Faction Armageddon is the same engine Saints Row runs on so no idea why they’re having problems. I’ve had no problems in any other Unreal 4 games aside from ADR1FT.

The games that do work are quite a big list, actually.
I was able to get most of the Assassin’s Creed games to work but Uplay makes some of them crash on startup so I was unable to verify if Black Flag, Unity and Syndicate worked. All the Batman games except Knight work pretty much flawlessly, as does the Bioshock collection, Bulletstorm Full Clip, CoD: Advanced Warfare, CoD: Black Ops II, Destroy All Humans, Dishonored 2 and Death of the Outsider, Far Cry 3 and Blood Dragon, GTAV, Halo: Master Chief Collection (requires modding mode to be enabled), Heavy Rain, Hitman Absolution, Homefront 1, Injustice 2, all the DX11 Lego games, Mad Max, Metal Gear Solid V, both Phantom Pain and Ground Zeroes, both Middle-Earth games, Red Faction Guerilla Remastered, Shadow Complex Remastered, Sniper Elite 3, the Spyro Trilogy, Star Wars Jedi: Fallen Order, the Tomb Raider trilogy (2013-2018) and the Vanishing of Ethan Carter Redux

The Witcher 3 crashes after loading for me using GoG version of the game with Global Injection.

The HDR works as you can adjust settings on the menu which is 3D but fails to load into game.

How does SK HDR compare to the HDR option included in Fallen Order?

It looks much better to me, being able to customise it further than the original game’s options makes Special K win by default to be honest.

It is working fine for me, you should disable the 11-bit remastering (it crashed my game too). I believe you can leave the 8-bit rendering but I noticed it makes Priscilla sleeve “black”. Leaving it off, it’s red again. I don’t know if it affect anything else so just to be sure disable 8-bit & 11-bit remastering.

Other than that, the JXR screenshot taken through Steam (with SK thingy to generate jxr files) are a bit too bright compared to what I see on my display but I suppose it’s because my HDR Tv sucks so my settings aren’t adapted to “normal” hdr display.
The game still look brighter than the screenshot in steam folder though.

1 Like

Protip: You can capture JXR HDR screenshots using Gamebar (WinKey+G) as well in Windows 10 v2004 nowadays. It’s possible those would appear slightly different from Special K’s screenshots.

Hey, thanks, I finally was able to try what you said. Unfortunately, it didn’t change the result: I get a too bright screenshot (.JXR), with a lots of details lost in the process and one which is normal(too dim?) compared to what I actually see on my display.

Can you think of any reason it can happen or can I (kind of) blame my cheap 4KHDR TV ? :smile:

It doesn’t bother me too much anyway because it looks pretty in game but it’s too bad I can’t really share it :confused:

Do you actually open and view the JXR photo on a HDR monitor while HDR is enabled, or are you opening it on an SDR monitor or with SDR mode enabled?

HDR JXR files will appear too bright when displayed in an application that either can’t output in HDR or when displaying in SDR.

Open JXR in a HDR enabled app while HDR is enabled…

  • HDR + WCG Image Viewer
  • Windows 10 Photos app

Thanks to you both, HDR+ WCG works fine. I think I understand better, I didn’t know you would need an HDR enabled app and thought that the setting (in display, win10) was enough to display hdr stuff through the Win10 photo app (didn’t work for me). Anyway cool

Yeah, basically if the app isn’t HDR enabled but you have HDR mode enabled, what is happening is that the SDR app opens the HDR image, displays it as SDR (too bright) and then Windows tonemaps it over to HDR based on the OS’ SDR brightness slider, and you end up with a really bright “HDR” image while HDR mode is enabled. The image itself is HDR, but a part of the display chain is SDR and screwing everything up. :smiley:

HDR still doesn’t see widespread use on Windows so there’s a lot of these random issues that you can stumble upon.

Another one that I notice every now and then is the difference in how apps are doing HDR-to-SDR tonemapping. There’s currently no standardized formula between apps from what I can tell so depending on what app or tool is responsible for tonemapping the HDR image over to SDR (proper tonemapping, so without the overexposure), you can end up with different results, such as for the below image:

SDR Conversion: Gamebar

SDR Conversion: HDR + WCG Image Viewer

Hi guys. I’m playing Bioshock infinite. SpecialK enhances it significantly, but I picked up an odd bug that I’m hoping someone can shed some light on for a fix.

When I watch one of the videos (in-game) in the telescope/kinetoscope, the video plays fine but when the video ends and it pushes you off the telescope/kinetoscope back into the world, the screen remains black and I have to alt-F4. While the screen is black, I can open the SpecialK menu but I can’t see it (I just see a cursor).

Any ideas? I would really like to have SpecialK working properly in this game as it does a great job, and I enjoy the lore - and the telescope/video things enrich the world, which is something I would not want to miss.

Edit: I tested with and without the remastering modes.

Have you tried it just with 11-bit rendering enabled? That fixed the black screen with video files in Just Cause 3 so it might help in Bioshock too.

Yeah. I tested with all the rendering options. It’s cool. I see that there will be some games with issues like this. I’m playing without the SpecialK framework as the kinetoscopes are used as a vehicle to deliver excellent Bioshock lore into the game world.

Kingdom Come Deliverance is broken with HDR enabled. It launches, but the videos do not play and the lighting is broken.

Witcher 3 works fine in 16-bit scRGB mode f you enable Borderless Windowed mode in game before turning on HDR. Heck, with all the texture formats upgraded. (even the 8-bit) Feel free to use SpecialK options to place the window where you want. Freesync works fine in this mode too.

This is because it tries to force old fullscreen mode and recreate backbuffer with different resolution on SpecialK which already enabled (sequential?) flip mode, where it is disallowed.
Alternative fix is to disable the checkbox for frame waiting, which allows resolution to change.