Trails of Cold Steel 3: DumpOnFirstLoad=true makes the game unable to boot

I want to do some texture mods/upscaling for this game.

Can you help me with debugging why this option is not compatible with the game? Thanks!

I haven’t tested with the demo though, but I think the problem still remains.

Can you upload your logs from a session where it crashed? These files in particular:

  • crash.log
  • dxgi.log (or SpecialK.log or whatever the main log file might be called)
  • modules.log

Yes of course.




Actually it doesn’t crash into Windows, but the game simply loads continuously and becomes Not Responding until I end it using task manager.

Edit: this also happens with Trails of Cold Steel 2 as well.

You’re dumping every frame of the opening video, I’d suggest not doing that :stuck_out_tongue_winking_eye:

1 Like

You might be better off manually dumping textures through the texture window anyway. Some textures won’t need an upscale. If you did dump everything, you’d still have to manually go through all the textures and remove what doesn’t need to be upscaled.

Surprisingly even disable the opening video (the game allows that) doesnt fix, but as GPUnity said, manually dumping the textures would work for now.

Is it possible to add a function to dump all currently available textures? :smile:

It wouldn’t produce results any more favorable than your current predicament. You could press the button, go out to get a bite to eat, come back and it might be done.

I understood what you meant.

I don’t mind trying to get the textures manually, but probably a function to select and dump textures (using shift for example) will make it feel much better.

Don’t forget you’re dealing with DDS files, and to my knowledge there’s no suitable way to preview all of them unless you download some likely dodgy software for the job.

You may have to convert each file as well, before upscaling, and then convert them again to the right DDS settings per texture.

There’s no convenient way to update a batch of textures, basically.

Thanks. I agree that preview a batch of textures would be a bad idea.

But on the other hand, I have found that using ImageEnhancingUtilities with ESRGAN can do batch processing with DDS inputs and convert into DDS outputs. For this particular game, its quite lucky for me that all textures (so far) have the same BC7 format. :smile:

What I meant is just an utility or GUI to faster dump textures from the list. But I can manually go through the list at the moment, and actually its probably not necessary after all since probably this is a rare situation where the user needs it.

Sorry to go back to this topic.

For some reason I tried to get SpecialK version 0.9.24 to attempt texture modding, not only for this game but also Trails in the Sky and Trails from Zero.

The DumpOnFirstLoad function works normally on that version, and I was able to grab those textures quickly. I guess this seems to be a bug on the current version, is it not?

By the way, the current version and 0.9.x don’t do texture injection for Trails in the Sky game (DX9). I found it to work on 0.8.66. Even though I am very happy when it works, I still want to report this if this can help other texture modders.

Edit: auto dumping doesn’t work with or without HDR.

Yeah IEU is pretty good for ESRGAN, can also pre-tile before upscaling and then cut off the excess to combat the seams that upscaling normally causes, which is something I’ve noticed a lot with upscale projects. I don’t have it set to compress the output to dds, as I like to keep png files and project files for gimp backed up and compress from them using Custom Texture Tool PS

I’ve noticed issues with DumpOnFirstLoad recently too, some just had a black screen on startup, and in a couple I tested, the option instead acts like generate mipmaps but generates them whether they had mipmaps originally or not, and makes textures without mipmaps get cached again if you have the option set to not cache them. Persona 4 and Okami did this.
I wonder if the reason it’s just a black screen on startup is because it’s trying to dump and generate mipmaps for everything?

An option to bulk dump everything currently shown in the texture viewer list is something I’ve mentioned before, along with one to purge everything from the dump folder that has a replacement.

The latest version that worked for me with dx11 texture injection was (AKA SK_0_10_HDR), good to know that 0.8.66 works for DX9, related to Trails in the Sky, I noticed that with newer versions only the UI textures seem to be shown in the viewer (I remember in old versions it was the opposite and UI were the only thing that didn’t seem to show)

You can add the games to the compatibility list, and add useful information in the notes section.

Probably. I’d be surprised if SK could run games like normal, whilst dumping all the textures it can find.

I added to the List, will update it later with more games that I play.

I wonder if the reason it’s just a black screen on startup is because it’s trying to dump and generate mipmaps for everything?

I am playing a couple of games like that, but my games are JRPGs that are not very demanding to my GPU so I don’t feel any difference while dumping textures,

Hi Kaldaien,

Could you help to get the texture dumping function from 0.9x back to the latest version? I have been swapping those two versions to dump textures / play in HDR. Will be happy to get both in one.

Also, for DX11 texture modding, is there any way to toggle between injected textures/base textures like DX9? Maybe its me but the modding tools for DX11 doesn’t show the number of injected textures, their sizes as well. That makes texture modding a bit more difficult than in DX9.


I’m only speaking for Dx11 texture modding here, i haven’t tried Dx9 texture modding.

If you mean to switch between injected and vanilla on the fly, then you’ll need to use the reload injected textures option. It would be an awkward setup. It might not work perfectly either, i believe reloading textures only works properly when it’s the same texture size as what’s already injected?

You basically need two versions of the injected folder - one being your injected textures, the other being the vanilla version of injected (with the same names). You can overwrite each other’s contents and use “reload injected textures” option in the texture view window. If you’re only checking a few textures at a time, you can speed up the processing by just manually replacing the textures you’re focusing on.

The alternative, and simple way of doing things is to just set inject to false (under the textures row) in the .ini file. This will require a fresh launch of the game each time you want to change the settings. You could also just rename your texture folder when you want SK to ignore it.

My suggestion, and basically what i do when texture modding, is to just save screenshots with the vanilla textures and use them as reference - you can alt-tab between game and screenshot, or just leave the screenshots open in a second monitor if you have one.

Thanks, I found out that the injected textures are required to match in terms of the number of LODs and the compression format. After figuring them out, I was able to see the new textures in the game.

In DX11, looks like your suggestion of swapping folder is the way to switch between original and injected textures.

Hi Kaldaien, sorry for asking in this topic again.

As I want to upscale all of the textures of those Trails of Cold Steel 2 and 3 games, currently I am having to swap between SK 0.9.25 and the newest SK. The former can do DumpOnFirstLoad for fast extraction, and the latter can play the game in HDR.

So its almost like I have to play the same content twice while swapping SK to achieve this. For many other DX11 games, dumping doesn’t have this problem so I can simply use one single version. Could you help me to fix this function on the latest SK ? (I used up to I think this is rude but I can donate more if this can be done :innocent:

Does auto-dumping work with HDR injection disabled?

No it doesn’t work as well. I see a white screen flashing and then the game crashed.

This is for Trails of Cold Steel 2: