Issues using some specific Special K fixes

Hey guys,

Since things have moved away from Steam, I was hoping it would be possible to find the issue I was having with a few specific game mods:

Using the latest version of the FAR mod on Nier Automata, I managed to fix using the override resolution that was pointed out to me on the discussion thread there (is it possible on the latest version for the game mod to get the resolution right without forcing it on FAR control panel?);

Doing the resolution override on .hackGU though didnt’t yield the same positive results (the game set to 2560x1440 fullscreen on the game options, but changes my resolution to 1920x1080 when using the .hack GPU Fix), tried setting min. and max resolutions to 2560x1440 but it still bugs it (to this weird 2544x1401) and with this settings forced when I select one of the games in the collection it crashes back to the desktop (seems almost like there’s an instance kinda thing because when I open one of the games the screen flashes a bit before getting to it)

Attaching the SpecialK.log from the .hack profile folder if that can give any help
SpecialK.log (23.7 KB)

If I recall, there’s an option for BGRA colors in that game. I also seem to remember deleting really old code for .hack//GU recently because it was in the wrong place (it worked, but was clogging up code that 99% of the time has nothing to do with that game :P)

You may be better off using an older version of Special K for that game. Usually the mods that SKIM can install are very extensive overhauls and have specific version requirements. .hack//GPU (mod for that game) is one such extensive mod.

So using SKIM in this case is the better way to do it, does the FAR mod fall under the same category? (or using the override should be fine if everything else pretty much works fine on the newer version?)

So, about using an older version of the .hack//GPU mod, installed the which is the one SKIM installs, but ingame there’s some really weird bugs (seems related to how the shadows are drawn), also the fact that many times the game just doesn’t wanna start with the mod installed, when I have the shadows option ingame on high, whenever I get close to a light source the game goes from 60fps to low 30’s with 100% gpu usage (this on a RTX 2060 and a Ryzen 7 3800X on 1440p which I find hard to believe that it’s a GPU bottleneck) also the GPU shows 100% but the temps are much lower than when it actually hits 100%, the way this game is working on PC almost makes me buy the PS4 version and forget I ever bought it on Steam

How the game stays when using shadows high and going outside the game hub:

There’s also this weird menu bug where the game just becomes a stutter mess:

Do you guys have any idea why is this happening? Really wanted to play this on PC but there’s so many weird issues that it’s almost making me give up.

Turn off the mipmap generation feature.

Thanks for the help Kaldaien, turning off mipmaps worked, strangely enough the menu bug still happens (less grave as it hits 100% GPU but the FPS stays around the 50’s instead of 15)

I don’t see any evidence of stuttering in the screenshot you provided. But it’s using the text-based framepacing analysis, which I guess is subject to interpretation.

The hitches=... counter measures the number of frames outside of 2 standard deviations in the last 120 frames. According to the OSD, you didn’t have any and that’s generally smooth enough not to notice any kind of weird timing issues anywhere except for the framepacing graph.

In fact, if anything, the first screenshot (from outside the menus) is the one with stuttering, it’s got s=1.38. The higher that value is, the less consistent frametimes are. This is the number used to assign color to the framepacing graph, BTW.

I fell this is more due to this game being terribly ported though, since it didn’t sell wonders on PC there’s not much info on the bugs, saw people mentioning the shadows option causing the game to stutter massively when facing sun shafts like the ones from the City (albeit on much lower hardware since they were posts on steam forums from near release date around 2017) and lowering shadows and disabling the mipmap generation as you mentioned improved it a lot, the stutter I mentioned is… Well from running the game menu at 15fps, definitely doesn’t feel smooth (even with no dropped frames, for the hardware I’m running it doesn’t even make much sense for it to happen) but it’s probably due to the bad porting of the game.