How Do I Get The Witcher 3 To Work With Special K?

I have The Witcher 3 installed through GOG. The install directory is:
C:\Program Files (x86)\GOG Galaxy\Games\The Witcher 3 Wild Hunt GOTY

I can’t seem to get the game to work with Special K. I have tried adding the directory to the Whitelist Patterns in ‘Injection Config’…but the Special K menu will not show up in-game (tried ctrl+shift+backspace and ctrl+shift+tab). I do have global injection enabled.

Please help!

Are you positive that Documents\My Mods\SpecialK\Global\whitelist.ini exists? Some users have reported SKIF isn’t creating that file.

If it doesn’t exist, create it manually then stop and start injection so that SK responds to changes in the INI file.

You can also just place a file called SpecialK.dxgi in the game’s install directory to avoid using the whitelist.

I do not see a file called SpecialK.dxgi

That’s why I said you can put one there. It doesn’t matter what it contains. it’s just the filename that matters.

Yeah, I don’t know…I don’t know how to create a file. I can create a folder or a text document…I tried creating a text document and naming it specialK.dxgi in the Witcher 3 folder but it still does nothing.


echo > SpecialK.dxgi

Huh? I don’t understand.

Open file explorer, go to the game’s directory, press alt+d, type cmd.exe, press enter

Then type:

echo > SpecialK.dxgi

I did. Nothing happens. It just goes: C:\Users\Sean

I then place: >echo > SpecialK.dxgi

I hit enter. nothing. After that line (C:\Users\Sean>echo > SpecialK.dxgi), It creates a new line with C:\Users\Sean.

Wait. Wait. I did it properly. Hold on.

Alright, the DXGI file is created. Booted up game. Nothing. Still can’t open Special K in Witcher 3.

I’m so freaking close. Okay, I deleted all SpecialK.dxgi files I created. Found out that my Witcher 3 is actually booting from a deeper location in the GOG galaxy folders…so I located the exact launch directory, place the .DXGI file in there…and when I ran the application, I was told that SpecialK will delete Ansel while running the Witcher 3 ( something like that?)…I hit okay, and nothing happened. I ran the application again and it opened for half a second and closed. It says the game is running (shows in my task manager) but no game is open. I have tried starting it again and it still closes almost instantly. SO CLOSE!!! Any ideas?


Hmm if there’s a Steam_Api64.dll file in where Witcher3.exe resides I wonder if you might not have to add


To the SpecialK config file to disable the Steam functionality, sometimes GOG Galaxy and Steam API files kinda both exists in either version of the game and that can be problematic for compatibility.

I’d try with GOG Galaxy disabled also but I think it should work depending on how it hooks into the API.

My own preference is to use the SpecialK stuff locally though as D3D11.dll or DXGI.dll and on that note check so that GOG Galaxy doesn’t have their own D3D11 or DXGI dll files already present if that’s a potential conflict as well. :slight_smile:

It gets a bit complicated if you have multiple API’s working like this where there’s Steam files even without Steam or GOG Galaxy in the Steam version without GOG running and then possible issues around if Galaxy has it’s stand-alone Galaxy 32 or 64-bit .dll files or interacts directly through their own D3D or DXGI .dll files which might be causing compatibility issues with SpecialK. :slight_smile:

EDIT: Hmm maybe GOG Galaxy on the SKIF blacklist could also potentially help but the game would need to be whitelisted I’m pretty bad at using the launcher so not much I can contribute with for how to set it up or utilize it best here.

Since I’m more of a local installation user so that would mean either the latest stable or beta build and using that.

Latest beta files would be from that post, SpecialK64.dll as DXGI.dll or D3D11.dll which means the config file would be named DXGI or D3D11 .ini next to Witcher3.exe the main game .exe not some launcher exe or how it’s set up for the GOG edition if that differs compared to Steam.

Best to get the global launcher build working and possibly also without using these WIP builds though. :slight_smile:

Something like that I think far as paths and everything.

Bit of editing there, I miss or forget a lot of info I was actually thinking it’d be the .\Witcher3\ folder but it’s a sub folder and then a secondary sub folder within that. :slight_smile:

EDIT: Pathing and listing if going through SKIF should also reflect this I believe.
(Just in case there’s a smaller separate launcher exe or similar elsewhere and that’s causing a snag here.)

You did it. I had another dxgi file in my directory that seems to have been interfering. I moved the file to desktop for now, and the game boots with SpecialK enabled. HOWEVER, it seems the the dxgi file I moved was allowing another mod I had installed to work properly. Is there no way I can have both files in the directory? I really like that mod =(

Ah so in the end it turns out it was one of the .dll mods yeah I think you can have both if that file can be D3D11.dll or if SpecialK can be DInput8.dll one or the other. :slight_smile:

I completely forgot the game had that system for mod support now.

EDIT: Loading both .dll files early so you get the functionality of both without compatibility issues is the idea behind this and getting the naming and such sorted or to allow for either SpecialK global or local installation to work and with the mod still active as to retain it’s functionality.

Problem after problem. Great, now the game crashes after I try to load a save. A Metal Gear Solid sound plays and the game goes down. GRRRRRR

That’s the SpecialK crash reporter kicking in, you should have log files now but it’s probably between the .dll files would be nice if both could work but something is causing it to crash on trying to initialize the game now.

Hmm wonder if that means the mod isn’t activating and loading and what it tries to help with is causing a exception as a result when trying to load into the main game where this was previously active and doing it’s function.

The game only crashes when I enable HDR in the Special K menu. With HDR widget set to SDR, the game runs.

Use an updated version, or fiddle with the remastering settings.