HDR for "Rise of the Tomb Raider"?

Hello,

first of all, i’m new to “Special K”, so i hope my question is not to dumb :slightly_smiling_face:

In love the HDR-Implementation of “Rise of the Tomb Raider” on the XBox One X and i know that the pc-version never got an HDR-patch. In the PcGamingWiki i found the following text:

“In 2018 the framework innovated a general-purpose method of “retrofitting” HDR output support for existing Direct3D 11-based SDR games in Windows, a feature that has since continued to evolve and in 2020 was updated to support most D3D11 based games compatible with flip model presentation.”

So is it possible to achieve an HDR-effect for the pc-version of this game with special K? And if so, how can i enable it?

Greetings,
Chris

HDR does work for the game. Run the game in Dx11 mode and make sure you’ve set the game to exclusive full-screen mode.

Use Ctrl+Shift+Backspace to open the SK control panel when in-game, and look for the HDR widget option. It’s self explanatory from there, and you will need to restart the game for HDR to apply (you will see a request to do so).

Edit: You may need to add the -nolauncher command line to bypass the launcher, which SK may hook with.

Many thanks for the quick answer! I got HDR to work, that really helped. That’s SO amazing :smiley:

I have one more question regarding the source color space. How can i know which one is the right one? Also i’m unsure about the “Non-Std. SDR Peak White”. The standard-value is 300, but nothing happens when i change it.

For the peak-white-luminance i choose 1000. That should be the correct fit for my monitor (PG35VQ).

Typically you don’t need to touch the colorspaces. Only change those if the colors actually look wrong.

If I remember it correctly Non-Std. SDR Peak White is used for the SDR-parts that doesn’t get HDR processing done – basically if you lower Horz. (%) HDR Processing or Vert. (%) HDR Processing to less than 100% you should see its effect on the non HDR-processed areas. Leave it as 300 nits.

In general Peak White Luminance does not need to be set higher than what the monitor reports. Basically ensure that Enable FULL HDR Luminance is not enabled, and then set the Peak White Luminance slider to the max, whatever it may be. For example, I have an Acer Predator X27 which has a peak brightness of 1000 nits, but it reports 698 nits or something like that and so that’s what I have set Peak White Luminance at (which is basically the highest the slider can go without enabling full luminance).

A higher value can cause clipping or something like that, I believe.

Edit: Yeah, that was the issue:

To avoid clipping extremely bright details, it is suggested you DO NOT enable Full Luminance Range and instead work with the default slider limits for peak white.

1 Like

Many thanks for the clarification. Then i will disable the full hdr luminance and set the slider to the max, which is also 698 nits in my case.

One further question regarding reshade, although it’s a little offtopic. SpecialK says that i should install reshade to My Mods/SpecialK/Plugins/Unofficial/ReShade64.dll. From where can i get the “ReShade64.dll”? And is this the only file i need to enable reshade?

Check the Plugins folder from your downloaded SK file.

You will also need to download Reshade 3 shaders, otherwise Custom/Unofficial Reshade will have no shaders for you to work with. I’m not sure where you can find a repository of shaders though, i believe @JonasBeckman knows? I don’t know if he’s online right now.

I have some Reshade 3 shaders saved here, not all of them
Reshade.zip (7.7 MB)

Your right, the ReShade64.dll is already in the directory. I installed the shaders, but unfortunately i still can’t check the reshade-plugin-checkbox in the specialk-ui ingame. Any ideas?

Ok, i can activate ReShade under the Unofficial-Tab. I first tried “Third Party”, where ReShade is also listed. My mistake :slightly_smiling_face:

But how can i configure reshade? The “Home”-Key doesn’t work.

Third Party Reshade won’t work with HDR - Reshade by default is limited to 8 bit colour space iirc. Custom/Unofficial Reshade is needed for HDR support (among other SK specific features).

Use Shift+F2 to open Custom Reshade.

Great, thanks.

I just noticed that GSYNC is deactivated since i enabled HDR. When i delete the Game-Profile under “My Mods/SpecialK/Profiles”, GSYNC is activated again. But when i activate HDR, then GSYNC is deactivated (Status “Supported + Inactive”). Any ideas?

In the SK window, look for Swapchain Management under the Direct3D11 settings tab. Set the Presentation Interval to “-1”.

“Presentation Intervall” is already set to “-1”.

Hover your cursor over Presentation Interval, you should have a tooltip indicating what value(s) disable G-Sync.

The tooltip says that values greater 1 will disable gsync. So -1 should be fine but still doesn’t work :frowning:

These are my Swapchain settings for ROTTR
image

I don’t know if these values will work for you, you can see in the upper right that G-Sync is active for me.

Interesting. I have the exact same values. Can you provide me your profile-file for this game? The thing is, in the SK UI under “Display” it says “Windowed Mode”. Maybe that’s the issue? When i try to switch this to “Fullscreen Mode”, then a cryptic error-message appears. I would provide screenshots, but i can’t upload anything here because i’m a new user :frowning:

EDIT: Here are the pictures. The first one shows the dropdown-menu, in which “Windowed Mode” is selected. When i try to switch that to “Fullscreen Mode” then the error-message in the second screenhot appears. I’m not sure if this has anything to do with my gsync-issue, it’s just a guess :slight_smile:

Imgur

Imgur

Have you set the game to exclusive full-screen mode in the display settings? That might be why.

You can also enable G-Sync for windowed mode in the Nvidia control panel, though i don’t know for sure if that will solve your issue

The game is set to exclusive fullscreen and in the nvidia-controlpannel GSYNC is activated for both fullscreen- and windowed-mode. Unfortunately it doesn’t help :frowning:

@Kaldaien Know what’s going on here? Game is Rise Of The Tomb Raider. HDR and Custom Reshade work fine for DonC, it’s just G-Sync that won’t function. All work well for me, so i’m not sure what’s going on in DonC’s case.