Godfall (Epic Exclusive,

Hey, wonder if someone could help me and see if it’s possible to get Special K running with GOdfall (Epic Games exclusive, )

Needs to be connected to a online server while playing , all save files are there appareantly, no saves on pc or other config

Its only DX12 so i assume the same fix to the configs must be applied like the Horizon Zero Dawn one

Also i noticed that in game you can turn all settings to low, but the effect/setting never turns completely off if that makes sense (like when you turn AA from off to on or the other way around your screen kind of flickers a bit, at leas mine, here thats not the case), basically you’re forced to have a little bit of each effect at least, while

It’s generally not recommended to inject multiplayer games, it’s at your own risk. I don’t think anyone here knows what anti-cheat measure Godfall uses (if any).

I think the only features SK supports in Dx12 are improved frame pacing and performance logging. Copying the dxgi.dll and dxgi.ini file to where the game’s executable is located should do the job, if you want to still risk it.

This was released recently for AC Valhalla, which is a Dx12 game, will probably work for Godfall.

Thanks! Ill give that a try now :slight_smile:

And yeah, thats the weird thing, there’s forced online connection but no anti cheat it seems, and when i run another epic online game (Dauntless for example) the anti cheat software is clearly there, its not a PvP game, its just kind of like MOnster Hunter as in you can help eachother do quests

Btw, if you want to use Global Injection, you can add the Godfall executable to the whitelist


If you don’t know the name of the executable, you can check task manager while the game is running.


following error occurs:

GPU Crashed or D3d Device removed. Use -3ddebug to enable the D3D debug device.

Use -gpucrashdebugging to track current GPU state."

The weird thing is: The game just keeps running in the background with sounds and all playing, seems as if the game didnt actually crash at all but i cant put it on foreground

Perhaps the game doesn’t like any injector? I suggest trying something like Reshade and seeing if you get the same error.

Btw, it just occurred to me the backbuffering count of the dxgi.ini file i shared may be too high for Godfall. Setting it to something like 1 or 2, and having the game run in borderless mode may fix your issue. If it works, you can slowly push it till you reach the max the game allows (while maintaining stable frame-times).


What settings did you originally suggest?

I kind of need to implement safeguards against setting the stuff too high. I know that AMD drivers @#$% the bed with more than 4 or 5 backbuffers, NVIDIA seems to support the entire 16 buffer maximum required by DXGI and … Intel I don’t know, who honestly cares if Intel’s drivers work when their GPUs aren’t capable of playing games? :stuck_out_tongue:

OP wanted to try Godfall with SK. I don’t own the game, but it’s Dx12 so i just shared your AC:V fix - completely overlooking the backbuffer count being pushed to 6 with the AC:V config.

Oh… yeah, that could be a problem. Some D3D12 engines do not handle arbitrary backbuffer count well.

As soon as I become more familiar with D3D12, I’ll be able to fix that.