FF VIII Remastered crashing before it even starts the game

Hey guys so tldr, I’m having an issue with FF VIII remastered where my FPS drop to 21 and don’t budge. This is apparently a common issue between windows v2004 users (may 2020 update).

In one of the steam threads (https://steamcommunity.com/app/1026680/discussions/0/4276687120031102568/) Someone mentioned SpecialK fixed it for them with a ton more people saying the same in one other thread.

I basically did everything that guy did and tried to launch SpecialK. Nothing, game crashes without even starting the launcher, no logs, no reason why, nothing. If I try to inject locally by just adding the specialk32.dll file and renaming it to OpenGL32.dll, nothing, same crash. Global injection ? Same crash.

For reference my setup is:
GTX 2070
I7-9700k
16 gb ram

Could someone give me a hand here?

Special K has great compatibility with OpenGL generally, this is weird.

I just tested on my tablet and main dev machine using SK 0.11.0.48 and have no problems.


There are multiple problems being discussed in the thread you linked. Are you trying to solve issues with low framerate when there’s idle input or something different?

I’m trying to solve low framerate issues as a whole :p. Seems like the only way to do it in FF VIII is through Special K, according to anyone who fixed this problem.

First of all I need the game to load with SpecialK turned on though, and it doesn’t work. I’ve updated to the latest version (was using the old GitHub one) and now the launcher just relaunches itself whenever I press “Play” if the service is turned on. There’s no crash logs or anything of the sort so I can’t figure out what might be going on :. I’ve tried launching other steam games and I get the same problem no matter what I’m trying to launch, so maybe it’s related to my computer and not to the game.

This sounds like you have some weird third-party product interfering, perhaps an overlay / video capture software or some kind of Razer product (they’re all bad). With no logs to go by, you’re going to have to try turning stuff off till it works.

To be honest, usually the only kind of software that could prevent Special K from working without so much as generating a log file, is anti-virus.

I do have a razer keyboard with cortex software installed. The only kind of overlay I might have is the nvidia geforce experience overlay. I’ll try disabling both of those and the antivirus and see what works

Just tried with both of those disabled and antivirus disabled to no avail. Same problem

Ugh, that sucks. I’m really at a loss for diagnosing this… those logs are important, and if stuff’s broken to the point where logs aren’t even being generated I’m useless :frowning:

Maybe another member of the community has some ideas, I unfortunately don’t excel at troubleshooting problems when my software’s not outputting the logs I designed it to :slight_smile:

Sucks but I guess I’ll wait for someone to share a solution :frowning: this is really sad but oh well.

This seems to be happening with steam games only. Tried some other non steam games and the’re working just fine

VIII’s 32-bit I believe.

In the Steam client install folder if you right click and go into the properties menu for GameOverlayRenderer.dll

Security

Advanced

Add

Select a Principal

Enter your account user name and choose that

Switch from allow to deny

Show advanced permissions

Uncheck everything but “traverse folder / execute file”

Ok / Apply / OK (Confirm on apply that you want to do this.)

It’s a bit lengthy but this is done to unload the 32-bit Steam overlay .dll from loading for testing.
Normally you can just rename the file but Kaldaien mentioned on the Steam community forums how a more recent change to the clients behavior is to keep this loaded into memory so I’m not sure it’s that simple anymore.

If performance is no longer affected it can be at least tracked down a Steam overlay issue going by your last post on how non-Steam games work fine.

In SpecialK setting Silent=True for the config file and not using any Steam functionality could also work for the other end of this issue assuming it’s the overlay that is.

EDIT: Oh and then edit and delete the added security permission or delete the file and let Steam validate and add a clean one so you don’t forcibly stop the overlay for all 32-bit programs. :slight_smile:

Unfortunately there’s no easy way to just skip the overlay for one game and the client toggle just hides it from drawing you still get the GameOverlay.log file and activity, it’s just invisible.

EDIT: And then the larger issue is resolving the actual problem without losing functionality, overlay has some uses tied to it both for Steam itself and SpecialK’s usage for it.

Confirms (hopefully) where the issues coming from but yeah resolving it is a different matter.
There’s a few settings in SpecialK but I don’t think they’d help here.
(Loading some stuff early or attempting to load a Steam API file and functionality among some other settings.)

EDIT: And I’m mixing multiple problems here, first there’s the crash problem then there’s SpecialK and somehow resolving a performance issue with the game?

Yeah I’m reading this wrong sounds like a general Steam compatibility issue, maybe Silent=True will work then to skip the Steam functionality from SpecialK.

EDIT: And being terrible at explanations it’s this. :slight_smile:
https://www.pcgamingwiki.com/wiki/Special_K

Overlay itself is compatible but something is crashing early on that there’s no indicative logs as to what.

Potentially the AV’s going at it and toggling that off might keep some background scanner going or there’s some active hooks like from Razer still interfering even if the main software is shut down.
(Which ideally also turns the program off not just the interface or settings program.)

It’s almost certainly the case that if my software’s not even generating a log file, then it isn’t going to read the config file and do anything any differently before things break :slight_smile: The log files are written to before the config is loaded.

1 Like

Hmm third party then or anti virus stopping it early in the injection routine.

EDIT: Which means either problematic D3D hooks from other software like input and well quite a few actually.

Or a anti virus is acting up this can also include Defender itself and others might not even prompt before stopping the dll hook attempt if the file itself isn’t quarantined also.

EDIT: Task manager might have some additional running programs for either for what to look for.

But why only with Steam?
Well it does possibly narrow it down to hooking problems with other software when the overlay is added to this mix.

Wonder if it’s Cortex.

Now what processes does it use.

EDIT: And what is it doing in there with some of these settings.

Sorry in advance I’m not a huge fan of automated “tweaking” software, some of them can have a use but there’s potential issues and compatibility concerns with some of these. :slight_smile:

So a process affinity thing, C state sleep disabling and some other overrides and RAM cleaning which I hope is just the standby memory and nothing too invasive.

Suspension of processes and other stuff as well.
(Suspending SpecialK perhaps, just a guess though and again Steam only so it’s not in everything.)

Plus how much of this is still active if anything after turning it off.

Cortex certainly doesn’t help anything, but the OP reports turning it off if I read their troubleshooting steps unfortunately.

I hate to speak ill of other software developers, but… Cortex is software that should not be enabled ever :stuck_out_tongue: Not just when it’s causing compatibility issues. It doesn’t really do anything important. It’s borderline snake oil.

1 Like

Yeah I’m trying to find some info if anything is still running after turning the main process off or if it needs a reboot to restore to a default state (With auto starting of cortex toggled off.) but then this seems to work fine just not with Steam.

But maybe it’s still related to having altered some process that Steam has although if that’s the case just shutting down and starting up the Steam client itself after turning off Cortex should resolve it. :slight_smile:

EDIT: I’m no expert but random unloading of RAM data, suspending processes and other tweaks can be a bit of a problem here for what the software has done and is doing even after shutting it down.

Maybe just restarting Steam will help though, getting the processes and services back to a default state and loaded into memory and active. :slight_smile:

I know Game Mode in Windows 10 had some plans in prior versions of Win10 too for process priority and suspending background programs come to think of it as a similar idea that Microsoft had.

Microsoft tweaked it a bit though due to issues with that so at this point it doesn’t really do too much if what I’ve found is current.
It suspends automatic updates.
(But it might return in a later OS build in some new form.)

Tried everything in here and nothing :. Funny enough it did create the config file when ran, but I don’t know if it read from it. All the logs on my profiles folder are absolutely empty too.

All third party software has been turned off and same for my antivirus. I have no clue what’s going on

Trying on my laptop now, trying to see if I’m gonna get the same results.