TBFix UI Not Appearing

So, I decided to get back into Berseria, went looking through some mods for spice, and came across Tbfix. It seemed like a big help, so I downloaded it and Special K and some mods.

For whatever reason, Tbfix and the mods in it never actually show up in my game. I can pull up the Special K UI, (v. 0.7.37, which is weird because my Special K Frontload is v. but nothing I do gets the Berseria-specific parts to show up. I downloaded the latest versions, Special K from the Discord update and Tbfix from the wiki, but nothing works. I’ve done everything the guide said am I missing something?

that sounds to me like you installed the wrong thing…

for berseria, my suggestion would be to make sure to run the tbfix installer from the tbfix sk wiki page


beyond that, some apps known to interfere or cause a conflict with sk are nzxt cam, rivatuner/rtss (in the case of rtss, you may try setting rtss to use ms detours), razer synapse, anti-virus…

I used the official wiki for downloading both Special K and TBFix. Ran the installation and there’s a TBfix folder with all the things I hear it’s supposed to have in my Berseria files as proof it was installed. It just doesn’t seem to register for whatever reason.

I did some more looking around and was starting to wonder if I need to use the SKIM install instead. I already have Special K and the version of TBfix you linked downloaded, but maybe that method will work better?

As for interference, I’m unsure what could cause that specific problem. Especially since I tried reinstalling them as Admin after the first few failures. The only item you listed that I have is Anti-virus, but there’s nothing indicating that was triggered. Still, thank you for the suggestions.

EDIT: Apparently, something I said was bad enough to flag my response. Not sure what or why, but my apologies if I somehow offended someone. Removed the links since those might have counted as a violation of the “post only your own stuff” rule.

hmm I’m not sure what flagged the post. maybe whatever links you had yeah

anyway, i’ve ran the tbfix installer and it worked just fine for me and apparently for other people too. It’s also better than the old SKIM installer – actually the tbfix is the same, but the one in the new installer has sk’s custom steam enhancements disabled by default because apparently, after a steam client update, the custom steam enhancements were causing the game to crash for people when getting an achievement

that and the SKIM option wouldn’t find the game if it’s not installed in the same location where the steam client is…

the new tbfix installer from the sk wiki should work, and it sounds like you got the files in your folder. I’m not sure why it’s not working for you. maybe try uninstalling the game from the steam client, deleting the game’s folder, and then reinstalling the game and running the tbfix installer from the sk wiki again

The links were for the wiki, so I’m not too sure there. I got flagged again the moment I reposted without them, so it must have been something else. Doesn’t matter, the mods let it go back up.

If it’s still working that consistently for you and others, then yeah, it’s probably some issue on my end that I can’t identify rather than some update creating issues. The TKfix folder is in my steam folder for Berseria so, unless it’s supposed to be somewhere else given I saw a video of someone making a folder for the Saints Row IV in Special K’s My Mods folder and putting everything there while I was searching for answers, I need to get a bit more through with my attempts.

I’ll see about uninstalling the files and giving everything another go. With any luck that should do it. Thanks again, I was starting to go nuts trying to figure out what might be wrong. At least this is a possible solution to look into.

That’s your issue then. The files shouldn’t reside in a separate TBFix folder. They need to exist in the root of the game folder so they actually get loaded when the game launches.

Having the files in a subfolder will mean they won’t ever be loaded.

Just wanted to confirm that the issue’s been fixed. At my best guess, it was a mix of some things not installing right for whatever reason and, later, the placement of some files. Everything seems to be working fine now.

Thank you everyone for all your help!