Tales of vesperia fix (combat slowdown/drops when hitting multiple enemies)


I am using the ToF fix
The fix really got rid of a lot of stuttering issues for me when running in town areas and the mini-map.
However I do seem to get some sort of slowdown/drops during combat when multiple enemies are hit with an arte or when free-running. The fix interface stays around 60fps though. I did not had this without the mod/fix. I did use the settings as suggested in this image.

There is also a tab specific for tales of vesperia with enable depth of field, sharper shadows etc.
Can anyone give me some advice or such what to tinker with that might affect the battle performance? If unclear I can try make a video.

Rollback your patch. I don’t know how easy that is to do with Steam now, but it used to be just a single command.

The prior patched version works best for the removal features.

Well I did find a solution that worked for me by putting the settings like this:

It runs fluid everywhere now however one thing is bothering. I have to keep the DWM tearing option on to prevent the screen going to flicker all over the place all of a sudden. I read that turning off the overlay of steam helps. I did that but the screen eventually starts to flicker again when i turn the DWM option off. The thing is with that option on you get tearing lines in the game. Is there another way to get rid of the flickering perhaps? Else I will try a roll back.

Try this instead:

dxgi.7z (7.8 MB)

It’s a much more recent version of SK, with a lot of work done for D3D12 compatibility. I may have solved that flickering problem in the process, I haven’t tested Tales of Vesperia yet.

DO use the waitable swapchain option though, I’m pretty confident that was making most of the improvement for you :slight_smile:

1 Like

I did replace the file with the one you posted. Been playing several hours now, not a single flicker so far! Kept the swapchain option on. Thank you so much! Finally able to relive this gem in a normal way!

1 Like