Tales of Symphonia texture injection with SKIF

Heya, I’ve been trying to inject higher-quality textures into Tales of Symphonia, but I am running into issues. Using the old TOS fix, it just doesn’t seem to inject at all. I’m guessing because SKIF is needed instead of SKIM.

If I use SKIM to try and inject textures, I hit this snag where the texture pops up in the window under BLOCKING, but it has 0.0 mb listed. There’s also no file system listed, and the texture change doesn’t go through. If I try to reload the textures, the game freezes and crashes.

Anyone know more about TOS modding and could help me out? Thanks in advance!

nope. don’t use skif for tales of symphonia. use tsfix from skim

to install tsfix, go the following link and download SKIM v0.7.5.15 -

https://wiki.special-k.info/en/SpecialK/Custom#install-type-skim

run SKIM64 – the one you just downloaded from the Special K wiki link
(it will also say “Special K Install Manager - (v 0.7.5.15)” on the title bar after launching it)

then select and install Tales of Symphonia “Fix”

after that, you can run SKIM64 again, select Tales of Symphonia “Fix” and this time, instead of using the “install” option, use the “Manage/Repair” option. This will then give you the option to install the optional add-ons/dlc stuff such as the 4k Upscale Texture pack, UI Clean Up etc

also, textures should be in-
\common\Tales of Symphonia\TSFix_Res\inject

like this for example-

image

tsfix can stream textures from .7z archives, so you just keep them like in the screenshot above. though, in fact, the ones from that screenshot are placed there automatically for you after using skim to install them (they’re part of the tsfix dlc stuff mentioned earlier)

also, the structure inside the .7z archive should be-

\Textures\Streaming

and the .dds textures will be in that streaming subfolder

for example, if you were to extract the 98_Cleanup.7z archive from the screenshot above, the structure will look like this-

but you don’t need to extract them, since, again, sk/tsfix here can stream textures from .7z archives, and keeping the textures in a .7z archive can allow for smaller files sizes.

i’m not actually sure how to dump the original game textures to disc with tsfix. i normally do that from the texture mod tools option in the special k cp menu, but tsfix doesn’t have that… maybe the d3d9.ini file has an option to start dumping textures on load or using a newer version of sk temporarily for the sk cp menu might work for dumping textures. i haven’t looked into texture dumping for tales of symphonia, but those are some ideas. anyway, texture injection should work with the structure and .7z archives as described earlier.

ah and another thing to keep in mind when you’re going to save your dds textures to inject later is the compression method that the original textures used. generally you’d have to match the same format/compression or save them uncompressed (uncompressed won’t work all the time or with all games though).

i’ve also not created any texture mods for tales of symphonia nor looked into what this particular game uses for texture compression etc - so not sure what would be needed on that front for this game. but basically i believe that if your textures aren’t working, it’s probably because of the structure/location you have them in and/or the texture compression you used. those are usually the key…

Heya, thanks for such a lengthy reply!
So I’ve done everything you’ve listed, step-by-step. I also uninstalled SKIF first in case there was any conflict.

The issue is, it just refuses to inject. I’ve tried it with global injection turned off and on, and TOS never loads the SKIM window. I used to use SKIM a while back, but I remember reading something about how Steam updated the way it works, and SKIM won’t inject anymore? Idk, but running it now, I can’t get it to do so. The window never shows up, and none of the setting/injections for SKIM do anything, even though it’s fully installed and set to inject.

Even holding down CTRL + Shift does nothing

what skim window ? tsfix doesn’t have a control panel menu with ctrl + shift or ctrl shift backspace. you can set some things in the tsfix.ini file though such as msaa levels if you want - otherwise the default tsfix settings are basically already good.

for symphonia you’d still want to use skim to install tsfix as tsfix is not integrated in new/recent versions of special k. don’t use any global injector for this game. basically this game uses local injection installed by skim.

anyway, the dlc texture mods do work if you installed them from skim using the “Manage/Repair” option as mentioned earlier and, if installed properly, you should be able see the archives for those in-
\steamapps\common\Tales of Symphonia\TSFix_Res\inject

i actually did a before and after comparison recently for someone else. you can see a difference in the title screen for example-

left image is with tsfix and using the 99_Upscale4x.7z archive for the 4k upscaled textures via texture injection

if you’re trying to inject some new textures you made, and you have tsfix installed correctly but the textures are not showing… then i guess it’s because of the way you saved them

also for reference, my game folder looks like this-
image

Oh, I’d assumed it had to run on global injection.

It still isn’t working, unfortunately, but I don’t know enough to troubleshoot (I compared the default textures with the injected ones (without messing with them at all) side-by-side, and there was no difference. I tried enabling/disabling several settings in the Ini, but nothing happened).

I’ve also tried running on a fresh install, of both the game and TOSfix, but it won’t actually cause any effect in the game. I’ll bet there is a solvable problem, but I don’t think I’ve got the patience to look for and solve it.

Thanks for offering help, anyway.