SteamVR causes dirt rally 2 to crash since using Special K

Hi there - first post, much appreciation for the developer of this amazing tool

I have an issue with SteamVR/Dirt Rally 2.0 and would like some help resolving it

I got special K about a month ago and tried it with DR2 (though not HDR, but that’s a different story), for some reason after I quit and then restarted the game, it pulls up SteamVR (as if I was using my VR headset, though it is not plugged in) and instantly crashes before the game launches.

I’ve uploaded the logs here

From what I can tell, the crash appears to be due to SteamVR, and not DR2.

Normally, DR2 works in both flat screen and in VR, and will launch SteamVR only if the headset is active while launching the game. Otherwise, the game will launch in flat screen mode as usual. However, since I first used Special K about a month ago, I cannot launch DR2 in flat screen mode (no headset) without it also launching SteamVR and then crashing.

Things I have tried so far & the results:

  • Stopping Special K service - still crashes
  • Checking “disable” against DR2 and SteamVR apps - still crashes
  • Verifying DR2 files through Steam - still crashes
  • Reinstalled DR2 through Steam - still crashes
  • Disabling RTSS as mentioned in another post - still crashes
  • Uninstalling SteamVR - Dirt launched normally and Special K works, so the issue seems to be with SteamVR
  • Reinstalling SteamVR - still crashes

I haven’t found issues with any other applications, but afaik DR2 is the only game I have that launches SteamVR in this manner if a headset is detected when launching the game.

Any help would be appreciated!


I don’t think I’ll be able to test/fix this because I don’t have a (modern) VR headset :-\ I had a model 1 Oculus Devkit and it was rather painful, I’m fairly certain the 1 headset I do have is way too old to work with anything.