Start at Logon not working?

I have Start at Logon enabled, but it doesn’t seem to actually do anything; I still have to start the service manually. What’s the service’s name so I can check in services.msc if it’s really enabled?

There’s no actual services — it’s basically scheduled tasks (through Task Scheduler) that runs a bat file that calls rundll32.exe with the appropriate command line to start global injection.

Might be that the bat file is missing as I believe Kal might be moving away from that solution.

Goal, I believe, is to actually make use of a traditional service when Kal is able to purchase the necessary code certificate.

Gotcha, thanks for the quick reply!

I forgot to include the task_start/stop.bat files that the logon option needs in a few of the builds. The version that’s been uploaded for a few days now has those files though, ensure the contents of Servlets matches the latest version in the Download link.

I did use the Download link just yesterday, but had a power outage so I figured maybe it got rollbacked. Just redownloaded it and nope, still no task_start/stop.bat files in there.

They’re named “enable_logon.bat” and “disable_logon.bat”.

Ah, then yes they were already there, but it still doesn’t start automatically.

task_enable, task_disable, actually.

I don’t have those in Servlet. Only disable/enable_logon.bat, task_eject/inject.bat, SpecialK.LogOn, and SpecialK32/

Meh, I’m no good with names.

task_eject/inject is what I’ve been thinking of all along. That was removed from earlier releases by accident, but it’s back and not a problem here.

Ah, but aren’t those also used to simply start/stop global injection through SKIF itself? :smiley:

No, SKIF just uses rundll32.exe directly now that it’s not on Steam anymore. The logon-launch option is the only thing that uses the task scheduler now.

Ahh, okay, now I get it. :+1:

And how do you make the task scheduler work?

You already have the necessary files so just check the start on logon (or uncheck/check it again) and UAC should pop up and prompt about adding a scheduled task at the start.

After that you should have a new scheduled task called SK_Logon or something like that.

Oh what, you have to have UAC enabled? Gross, I hope that gets fixed soon

Is there a way to manually add the task?

EDIT: Found the Task Scheduler and the task is indeed there, but it just doesn’t seem to work; I still have to manually start the service at launch. I’ve tried putting it on Delayed Start, we’ll see if that solves it; a few services seem to have trouble launching at the same time as everything, and Delayed Start helps with those

Can confirm, setting the task to Delayed Start did the trick