SpecialK locks fps to 75fps

Hi, the game in question is not a steam game
its a BF2 mod called PR which runs on directx9. iam using global injection method.
Both the game and skif are running as administrator.
please help (iam not sure if SKIF is forcing vsync or not).
edit1: not sure why this topic got posted in general; sorry.

What kind of settings are you using? If you are in Windowed mode, it could be DWM is limiting you to your Refresh Rate, or if you set say Present Interval to 1 (1 = VSync ON, 0 = VSync Off, -1 = Let the game decide).

iam using -1 and the game is in windowed mode but i alternate fullscreen mode with alt+tab.
edit1: forcing vsync off with nvcp has no change.

Is it this bug you’re hitting?


1 Like

that seems to fix it

Just goes to show, I guess, how little focus DirectX 9 have gotten over the last few years. That bug have been present in Special K since at least 2018 and version v0.9.20 – possibly even longer.

No it doesn’t.

Refresh Rate = 30 Hz

It’s not advisable to draw much above your refresh rate in D3D9 though. You’d need to add extra backbuffers to the swapchain to do it without rendering at (best case) 1 1/2 x Refresh Rate. SK doesn’t expose these settings in the D3D9 control panel (they require manual INI edits).

D3D9Ex is a little less restricted, it can draw as fast as it wants with only 1 backbuffer.


There does seem to be a driver bug that does this for D3D9 after changing display modes. Happens with or without Special K, and SK cannot override the problem either.

Avoid Fullscreen Exclusive in D3D9 if you want to draw > refresh rate

  • Driver will force V-Sync on otherwise.

@Aemony: Did you add that thing to the PCGamingWiki? It doesn’t really apply to me, it’s some kind of driver bug.

Weird, because as mentioned the issue have been present since 2018 and it happens on both Win7 and Win10 only when using Special K.

  • But I also haven’t really tried reproducing the issue myself in the last two years.

I can update the section on PCGamingWiki to mention how it’s partially a driver flaw, but at the end of the day the section will have to remain as injecting SK seems to be what triggers the issue for many.

Perhaps explain which driver/brand you’re using ?
and what ini settings are you talking about ?
edit: using an older nvidia driver (wddm 2.3) doesn’t solve this issue

I need to investigate this a bit more, but a cursory delve into it didn’t seem to indicate that the issue as it was originally experienced is still there. It’s possible you’re hitting another bug entirely.

The original bug saw all D3D9 games get capped to the refresh rate of the monitor at the moment that SK was injected, but so far I can’t reproduce that behavior in the couple of titles I’ve tested.