SpecialK FF8R - Won't Play

Hey,

I’m trying to get Special K to work with Final Fantasy VIII Remastered on a new OS with the same hardware but it’s just not working. The day before reinstalling the OS, I had set up Special K to work with FF8. I just downloaded the files, extracted them into the main directory, changed the dll to OpenGL32.dll and it worked. However, now, on a fresh OS, all it does when I hit PLAY is relaunch the FF8 launcher. As soon as I get rid of the files, the game boots.

I’ve tried a fresh reinstall of FF8R, updating Windows 10, checking Firewall & allowing the .exes through, tried turning off Windows Defender as I have no other anti-virus software and even disabled AMD’s overlay as well as Steam’s overlay. I even tried the full injector version, but it does the same thing too.

Any idea what could be the problem?

SOLVED

It turns out I stupidly forgot to install basic things like Visual Studio and DirectX. Today the latest Windows 10 update came out too, so I installed that. Basically I installed x32 and x64 versions of Visual Studio 2019 and 2013, DirectX and rebooted. Now everything is working again. lol

Hopefully this helps someone else, if they have the same problem.