So i've been trying to get Path of exile to work with flip mode but

When i enable it the game get’s all dark, also specialK breaks the cursor in the game, i also have a older installation of windows 1709 on a spare HDD, and the automatic flip mode promotion that was available in that version of windows doesn’t seem to make the game go all dark even if both are supposedly in flip mode.

Also when using the frame rate limiter is this information from Blurbuster still valid for low lag VSYNC ON for non VRR monitors by using decimal a frame rate target of -.010 of the refresh rate as reported here https://blurbusters.com/howto-low-lag-vsync-on/#:~:text=Better%20Low%2DLag%20%E2%80%9CVSYNC%20ON,perfect%20%E2%80%9CVSYNC%20ON%E2%80%9D%20motion.

Hmm according to presentmon tool the reported latency there actually goes lower than use VBLANK in SpecialK if i use the decimal refresh rates as explained by blurbusters dunno if it’s accurate though.

I don’t know what the problem with the cursor is, but for the brightness… I suspect the game uses sRGB gamma. I hate games that use that, it’s incompatible with flip model. I have developed an override for that, but then gamma no longer works correctly. There’s no good solution, the developer should simply not use sRGB.


As for all that silliness about specific rates to get lower input latency, I don’t believe any of that for a second. Special K has a new low latency limiter mode, it doesn’t work by fudging with numbers, it actually works by changing when the finished frame is presented for final output.

I would encourage trying SK’s new low-latency limiter settings instead of following guides that tell you there are magic numbers even if they were written by pretty respectable websites :slight_smile:

Yeah your correct the game uses, SRGB, I still find it weird though that flip mode via windows 1709 doesn’t have the brightness problem with SRGB, just curious but how would I enable this SRGB for testing?

EDIT: oh supposedly the override triggers automatically when flip mode is toggled?

Well. I came here to enquire about the same mouse cursor issue. Is there any useful investigation that could help shed light on that? I’d love to use the frame rate limiter if possible, but it sounds like that isn’t practical either?

What mouse cursor issue? Nobody’s defined it yet.

basically the mouse cursor ingame is only showing when your moving the mouse, if you enter speciialK options panel the mouse cursor will always show as it should, but it’ll be switching between the SpecialK cursor, and the ingame one while moving the mouse cursor.

I see.

Can I get you to try the version of Special K linked in this post?

Don’t expect it to fix the gamma problem, but that is Special K v 0.11.0.49. It is not yet released, but has had some work done on mouse cursor issues and may well fix your problem.

1 Like

The build you linked did fix the mouse cursor issue, but it triggers a crash when alt-tabbing in out multiple times though.

EDIT: yeah it always crashes on the second alt-tab in out, the first one is fine.

+ Added sRGB Bypass Mode for SDR games that need sRGB removed for Flip Model

 >> Games that used to be too dark can now use Flip Model

SpecialK64.7z (7.6 MB)


Incidentally… WTF?! This game stutters like crazy. It’s not render-related, the game’s just that terribly optimized.

Incidentally… WTF?! This game stutters like crazy. It’s not render-related, the game’s just that terribly optimized.

Yeah. The game is mad spaghetti code. Every major patch breaks dozens of unrelated things and it takes the devs around 4 weeks to get it back into an acceptable state.

Performance has been horrible from the beginning. Supposedly Vulkan fixes some of that, but it is still far from acceptable.

Yeah I know VRR softens the stutters but it will still happens, I think some of it is related to loading of mobs as some events in game aren’t preloaded and causes mad I/O loading stutter.

It does seem that just injecting SK seems to make the game stutter more though, compared to Rivatuner in heavy in-game scenarios with million effects.

EDIT: seems the game also doesn’t like waitable swapchains it crashes after awhile.

I’m having difficulty getting flip model to work… when I enable it, this happens.

@Kaldaien Do you have any advice? I need flip model in path of exile… fullscreen sucks.
logs.7z (12.7 KB)

Weird it’s working for me with a 1080ti, i only needed to enable flip mode, and restart nothing else…

Steam or the standalone client? I use standalone

Change the game’s settings so that it doesn’t start in Fullscreen Exclusive. That’s the only advice I can offer.


Also, WTF is this?

11/19/2020 08:54:26.146: [ Module ]  ( 00007FFD171C0000h + 00495616 )                                                         C:\ProgramData\Microsoft\Windows Defender\platform\4.18.2010.7-0\MpOav.dll
11/19/2020 08:54:26.148: [File Ver]    IOfficeAntiVirus Module  4.18.2010.7 (WinBuild.160101.0800)

I wasn’t aware that Path of Exile is Microsoft Office derived software :slight_smile:

https://support.microsoft.com/en-us/help/914922/microsoft-windows-defender-helps-provide-real-time-protection

Windows Defender registers itself as a shell execute hook. Windows Defender can block known bad commands from passing through the shell execute chain before they are executed.

Windows Defender implements the IOfficeAntiVirus interface to scan Microsoft ActiveX controls that Internet Explorer installs. Additionally, the IAttachmentExecute interface calls the IOfficeAntiVirus interface after Windows Defender enables the Attachment Manager Group Policy object. The IAttachmentExecute interface calls the IOfficeAntiVirus interface at that time to request that antivirus providers scan attachments.

Weird…

I use the standalone client.

I tried that and it crashes in all 3 modes of PoE 64-bit exe. (Fullscreen, Fullscreen Windowed, and Windowed).
I discovered it works with the 32-bit version of PoE, but that is really more of a legacy mode.

Special K actually provided crash logs this time… is there anything in here?

logs.7z (7.7 KB)

No difference that I can see. The game’s still trying to go fullscreen and breaking itself.