Shadow of the Tomb Raider mod problem

So I am going to apologize in advance for being such a newbie when it comes to using Special K and arriving at the mod party late. I am primarily a gamer on the consoles, PS4 to be precise, and the game I am going to be asking about below, Shadow of the Tomb Raider (SOTTR), I have already completed and platinumed on the PS4. The hardware I am using to play the game on the PC is a Razer Blade 15 Advanced laptop with an ASUS PA32UCX monitor.

I purchased SOTTR a few days ago on Steam and have played up to Paititi, where Lara is given the Blue Heron Tunic. Once she receives this Tunic you can then use the mods available to dress or undress her.

The mod I have installed from the Booty Edition is kind of working. I am running Special K v 0.10.0.1024 and have installed the dxgi.dll, SpecialK64.pdb, and Version folder, inside the SOTTR Steam game directory. The problem with the mod is that Lara from the waist up is one color and from the waist down is another color. Lara still has the same overall color, but from the waist up she is light and from the waist down she is dark. From the waist down she almost looks like she is wearing pantyhose.

So now starts my newbie questions:

(1) What version of Special K should I be using with the SOTTR? I have partially read the Special K v 0.11.0.45 post but I am still confused if I should uninstall the Special K v 0.10.0.1024 I am using and install Special K v 0.11.0.45 or some other Special K version from this website.

(2) If I should continue to use the Special K v 0.10.0.1024 is there a way to fix this problem I am seeing or is this simply a limitation of these mods in the SOTTR game.

I got to say that I am surprised that Special K even works at all with SOTTR since the game has the Denuvo DRM software integrated into it.

Any help anyone could give me would be greatly appreciated. Thanks.

I just tried Special K v 0.11.0.45 and it doesn’t appear to be working. When I get past the logos in the game, Crystal Dynamics, etc. The screen goes black and stays black. I don’t know if this is caused by Denuvo DRM software blocking the game or if I don’t have something configured correctly. I am going to try Special K v0.11.0.47 and see if that makes any difference, but I am unsure about v 47 since the notes in v 45 stated that was the last compatible version with Steam. This is why I am somewhat confused as to what new version I should be using of Special K or if I should stick with v 0.10.0.1024

The Special K v 0.11.0.47 did not work at all, which is what I expected. At this point until I get some feedback from this forum I will have to stick with v 0.10.0.1024, which sort of works.

Sounds like a texture cache problem.

Special K has no problem working in Denuvo protected games. In fact, it works around dozens of things that Denuvo does under the hood to make reverse engineering difficult. I have been modifying Denuvo games long enough to know all of what it does :wink:

As for versions, the latest version of Special K should be compatible. It’s download is linked at the top of the site.

Thanks for replying Kaldaien. Unfortunately, I didn’t really understand what you are saying. Let me see if I can figure out what you are trying to tell me.

I do understand what you are saying as far as Denuvo software is concerned.

What I don’t understand is what should be the expected behavior of the different versions of Special K. When I tried v 0.11.0.47 the game launched and I was able to get into the game completely, however the Special K UI that normally appears at the top of the screen did not appear, which I assume means that Special K was disabled for some reason.

When I tried v 0.11.0.45 I saw the Special K UI appear at the top of the screen, but the game never reached the game screen after the logos vanished. The screen remained black and I could hear the audio playing from the screen that you would normally choose to continue game play. I tried pressing the return key to see if I could get “Continue” game to launch, but the game ignored any keyboard input.

“Sounds like a texture cache problem.” - I am assuming this response is taking about the issue I am seeing with Lara and not something with the Special K software. How would I fix such a problem?

Again, I am sorry that I am not understanding what you are trying to tell me. Special K is very new to me and getting mods to work correctly is not always easy to do.

Are you running the game with the highest texture settings?

Yes. I have set the Texture Quality to Ultra.

Hmm, well unless the mod states a specific build of the game to use (for whatever reason), or it requires a specific clothing setup (and you’ve put on the right clothes), then i’ve no idea.

You can test other versions of SK in that case, if the latest version isn’t working.

BTW, GPUnity thanks for your previous replies.

Yes, I am going to try and put Special K in a more restricted environment to see if I can get it working. My plan is to use Parallels, with a Window 10 installation. By doing this if something goes wrong and Windows were to get messed up it would not be a problem. If I can get Special K to work in this environment then I could transfer the knowledge back to my real Windows 10 installation on my laptop. I am not going to try and play Shadow of the Tomb Raider in this environment I am just going to try and get Special K working first and then see what happens.

hello… I’m currently experiencing extreme problems with specialK. i do as i should when I install it to the game but once installed, I cant open the game. if i the remove the .dll file that comes with specialK it starts right away. any ideas of what’s causing this problem?

I have the same problem.
not figured it out yet.

Hi all, this is my first time trying this mod out for a bit of fun. It’s all working, but for some reason if I add e.g. a new singlet, it sits underneath the official tanktop. So you end up with the tanktop and you can see the straps of the modded outfit underneath coming out.

So it’s kind of working.

I don’t really have a reference here to know if this is something to do with new updates to the game, the nvidia drivers I have, the special k being out of date or if there’s some fancy way of clearing the cache which I haven’t found yet. Any ideas? Does anyone else actually have this working in 2022?

Thanks.

Sadly our forte is with Special K itself, and not texture replacement methods in any particular game. What I do seem to remember in Shadow of the Tomb Raider is that some texture replacements requires the in-game texture quality to be set to highest for the texture to be replaced (as it’s the highest quality texture of the game that has been replaced). Or if the mod replaces a lower quality texture, that setting would need to be lowered.

Beyond that though I’m not entirely sure what your issue is, but as I said our experience is with Special K itself – I don’t think any Special K staff member actually plays or has used Special K with Shadow of the Tomb Raider to the point where we can answer more advanced texture modding questions for that specific game (you probably want someone that actually mods that game instead).