Problems with Vesperia and DSR

Hello, I have a 2K monitor, but I usually plays Tales of games in 4K with DSR.
When I set the 4K resolution in the ini inside TvFix, it runs in a tiny window.
How can I do it full screen, and make it also starting full screen?

Hmm was Vesperia using DirectX 9 if so DSR is having some problems with D3D9 in the current NVIDIA drivers otherwise I think it’s just a matter of tweaking the default config values a little bit for this. :slight_smile:

[Window.System]
Borderless=false
Center=false
Fullscreen=false
OverrideRes=0x0

For D3D11 there’s also this.

[Render.DXGI]
MaxRes=0x0
MinRes=0x0
SwapChainWait=0
UseFlipDiscard=false

What I usually do though is to set the desktop resolution via Hotkey Resolution Changer.
https://funk.eu/hrc/

And utilize borderless downsampling by this method toggling key-bindings for native and downsampling resolutions as the desktop kinda looks really bad with downsampling active.

Might want to check so that the OS is also using 100% for DPI scaling and not 125, 150 or 175 % otherwise the scaling might be affected badly if the games not wholly DPI aware and you get a very blown up final image instead which doesn’t work at all.
(The OS tends to like to use 150% if you use 3840x2160 for example as a helper for super tiny desktop icons and the small font and such.)

Settings for that would be something like this through the ini file for SpecialK if you attempt to use it in this way for downsampling with a borderless image.

[Window.System]
Borderless=true
Center=true
Fullscreen=true
OverrideRes=3840x2160

[Render.DXGI]
MaxRes=0x0
MinRes=0x0

(Possibly 3840x2160 here for max res min res can vary some games don’t take well if it exceeds the expected often 1280x720 or 1920x1080 min res and might scale badly or crash on start.)

Flip model should work too I’d test it if the games using D3D11 after confirming SpecialK and down-sampling is working well together.

And for DSR and D3D9 it’s this issue.

The next NVIDIA driver might fix it, there’s going to be some good fixes of what I’ve heard through a few comments on it and fixes that have made it. :slight_smile:

I don’t think you have to manually set 4K resolution in Special K.
For me, I only have to set 4K resolution and Windowed Mode in Tales of Vesperia settings.

Then, in Special K settings, under “Window Management” > “Style and Position”, just check “:ballot_box_with_check: Borderless” and “:ballot_box_with_check: Fullscreen (Borderless Upscale)”
(In ini file, it’s “Borderless=true” and “Fullscreen=true”).
And the game will always start in fullscreen.

Waitable swapchains are probably enabled, which (used to) prevent resizing the framebuffer.

Special K 0.11.50 (or .48 or .49, can’t remember which) fixed that problem. You’re better off just grabbing the version at the top of this site and using it instead of whatever version you’re currently using.

1 Like

Sorry if I ask, but is it same thing than TvFix? The folder structure and files, looks pretty different.

The Vesperia plugin and respective enhancements should work though you’d have to replace the .dll with the new one from the download here and then opening up the on-screen display should show Tales of Vesperia Fix in the menu as a title indicating the plugin and it’s enhancements are active. :slight_smile:

EDIT: This is the case for most D3D11 plugins including Nier Automata and newer but not the earlier D3D9 ones and not Untitled Project X or Final Fantasy X’s enhancements if I remember it correctly.

Should cover Dark Souls 3 too but newer builds can get the soft-ban mechanic to kick in since DS3Fix 0.50 I believe was the last reported version where that didn’t happen and that should be mostly everything. :slight_smile:

I just tried updating to Special K 0.11. And Post-Processing options that remove blurry DoF and sharpen shadows no longer have any effect.

Special K 0.10:

Special K 0.11:

However, I think anti-stutter still works though because, as far as I can tell, there is no visible stutter at all.

@Kaldaien yesterday all worked great, but now, when I launch the game, it immediately crashes to desktop.
I saw some of your posts where you say that the new version of the game doesn’t allow to remove blur, dof, etc., but with the auto updated version of TvFix downloaded from Steam forum, I was able to have the game 4K DSR fullscreen without dof, blur and other stuff. It looked really gorgeous :confused:

Can my issue be related to Swapchain management? With default swapchain values, it worked fine, then I used values 1-3-4, as you suggested in a post, and if I’m correct, this was last edit I did. Also tried with and without Steam Overlay.

My logs:
DXGI
Modules
Can’t add the link for Game Output. So, here it is:
11/20/2020 12:15:29.503: #Extremely#Invalid.dll# : [S_API] SteamAPI_Init(): Loaded ‘C:\Program Files (x86)\Steam\steamclient64.dll’ OK.
11/20/2020 12:15:29.834: C:\Program Files (x86)\Steam\tier0_s64.dll : Missing interface adapter for SteamUser023 User
11/20/2020 12:15:29.834: C:\Program Files (x86)\Steam\tier0_s64.dll : Missing interface adapter for SteamUser022 User
11/20/2020 12:15:29.835: C:\Program Files (x86)\Steam\tier0_s64.dll : Missing interface adapter for SteamUtils012 Utils
11/20/2020 12:15:29.835: C:\Program Files (x86)\Steam\tier0_s64.dll : Missing interface adapter for SteamUtils011 Utils

I deleted dxgi.ini to make the tool rebuild the file, and then I edited all settings EXCEPT Swapchain. my current values are -1, 3, 4. If I use 1, 3, 4, the game doesn’t run at all.
Now, the game runs again, and as you can see, there is still a difference with or without DOF. I have the game on Steam, with latest update.


Without DOF: https://imgur.com/a/k4pX4aa

Sorry, but I had to post the image on another site, because forum rules for new users.

Last UPDATE: Sorry if I keep writing, but for some reason, now the game also works with Swap Chain values 1, 3, 4. All others Swap settings are disabled. I have no idea what happened a few hours ago.

In conclusion: I would like to know if I can play this way, or I’ll encounter issues/glitches, especially considering I’m using an old version of the tool? If I disable all Steam achievements options in the tool, do I still get original Steam popups?