Not working in Iron Brigade

I was hoping to use SpecialK to fix yet another 30fps double fine game from the 360 and ps3 era with stutter (thanks to DoLLo config I was able to play Custom Quest without stutter).

But SpecialK doesn’t hook, it doesn’t create any logs even. though it does a folder and a SpecialK.ini.
Is there anything I can try, what would be the steps for a game that doesn’t even get to the point of creating a log?

How have you tried injecting Special K ? Using global injection or through a local wrapper DLL file? And if you used a local wrapper DLL file, did you use SpecialK32.dll or SpecialK64.dll, and what did you name them to?

SKIF 0.7.03, both services run at logon, steam copy so it’s automatically trying to inject (under profiles a folder is created for the game + a SpecialK.ini file so it’s trying to at least).

According to SKIF strategy is Global DLL is SpecialK32.dll (

Can you upload the SpecialK.log file that resides in the logs subfolder of the profile folder?

PCGamingWiki sadly doesn’t state what graphics API the game is using so it might be that it’s using something that Special K can’t render unto or such.

Well that’s the weird and unfortunate part, it doesn’t create any logs. A game folder and a SpecialK.ini file, but nothing else. (My guess is it’s probably DX9 btw).

It’s DX9 and the framepacing in this one(not like CQ)is perfectly fine with NVCP@30fps.
If you use my old .ini from CQ SpecialK apparently start without any problem but the frame limiter don’t work. Don’t know why. I try the wiki “fix” for the DX9 games(disable full screen optimization)but nothing has changed, frame limiter don’t work. Use the NVCP one or AMD Chill.

1 Like

That worked, NVCP did resolve the issue with capping at 30FPS, though toggling the menu caused some stutter still unless I toggled a few more times after, it didn’t seem completely stable.

I decided to try one last time… and realized I stupidly disabled SpecialK in SKIF for Iron Brigade and forgot about it :sweat:. I see what setting is needed to make it load too know: LastKnown=8 to force DX9 detection.

And the really good news is that at least for me the frame-limiter does work! And very well at that after I adjusted “max cpu timer accuracy” or something along those lines in the overlay to a higher percentages. Left it at 60%. Didn’t realize the significance of this setting, in retrospect, I could’ve maybe also eliminated some of the rare stutter I still had in Custom Quest too if I set it more aggressively. Glad I realize it now at any rate.

Thanks for your help guys.

Nice to hear. Can you copy/share your Iron Brigade SpecialK .ini on pastebin?