NieR:Automata crashes with ReShade

I tried both FAR plugin from NieR Automata Mod Helper and the newest SpecialK, but game crashes at startup with ReShade enabled in lazy load order. Switchig to early load order causes multiple menu glitches. Logs show some d3d11.dll exception so I tried to disable the texture cache by changing the parameter Cache to false in the the Textures.D3D11 section and disable the hooks cache by setting EnableGlobalCache and EnableLocalCache to false in the the D3D11.Hooks and DXGI.Hooks sections and remove all existing hooks in those sections, but no effect.
Logs in GDrive folder:

did you try adding sk and reshade following each step from the nier automata section in the sk wiki’s reshade page ?


that method worked for me last i checked and apparently worked for other people too

Yes, when I tried SpecialK I followed that guide. FAR included in NieR Automata Mod Helper uses same pattern, I assume.

i wouldn’t assume…

make sure you follow the steps from that guide i linked from step 1 to 7

i just tried it on my end following every step from the guide i linked

sk/far + reshade is working here as expected-

I’ve just tried to follow this guide again, same results, crash.log shows exception with d3d11.dll in System32 directory. Reinstalling DirectX has no effect, maybe it’s because of 528.02 Nvidia driver I installed recently, but:

  1. I don’t remember what version was before;
  2. Crashes didn’t occur right away I updated driver, game launched correctly few times after.
    Also I’ve checked my old dxgi.ini and new autogenerated one, they’re identical (Compare plugin in Notepad++). And I’ve checked is there any mod conficts:
  3. Installing SpecialK with blank ReShade by guide and no any additional mods — crash;
  4. Deleting [Import.ReShade64] section from dxgi.ini — and all works (without ReShade, of course);
  5. Versions 4 and 5 of ReShade has no difference on results.

i was on the 527.56 nvidia driver when i tested this earlier

however, i just updated to the latest 528.02 nvidia driver, restarted my pc, and tried launching the game again with sk/far + reshade multiple times and it still works here without crashing – both sk/far and reshade show up etc

i don’t know what you mean by “blank reshade by guide.” the guide i linked doesn’t mention something about a blank reshade, and it instructs to download reshade from the reshade website – so the version i used was the latest from reshade’s website (reshade 5.5.2)

also you’re using some old version of sk according to your logs…

apparently you’re on sk version 22.9.25 – i’m on the latest sk version 23.1.3

and i’m not using any modhelper. i installed the latest sk locally for this game following the instructions from the sk wiki guide etc

“blank reshade by guide" is just .dll and default ReShade.ini without presets.
I used 23.1.3 version, same crashes with d3d11.dll, logs I’ve provided are from older FAR but newest 23.1.3 version has same problem.

welp i can’t reproduce that issue. it works just fine on my end following the instructions i posted, and i’ve also given them to other people and apparently it’s worked for them too.

sorry but i don’t know why it’s crashing for you…

if you figure out why it’s not working on your end, let us know – could help someone else i guess. though honestly i think you’re the first that tells me this doesn’t work for them with the instructions i posted…

All right. I’ll try.