Mouse Cursor disappears in P4G

I have “Hide when not moved” turned off, and I’ve checked and unchecked just about every setting that mentions the mouse to try and get it to appear-- no dice.

The game hides it when it sees input on a gamepad. You can always force the game never to see gamepad input under the Enable / Disable Devices section of the control panel.

this happens to me with no controllers pluged in and only with special k i would like to play with the mouse is there any fix.

ive been messing with the settings a bit it seems somethings wrong with auto hide it works when sk menu is open but auto hides quickly even though i have auto hide off an when its on and set to 30 seconds it still hides the mouse after 1.5 seconds disabling gamepad dosen’t help and like i said i have no controllers pluged in.

ok so auto hide appears to only work on sk menu if i set it for 30 second thats how long it will take but when the cursor is outside the menu its gone unless its moving.

Also sorry for all the edits just trying to provide as much info as possible.

ok so i found a work around by mongoose on steam for anyone having this problem in sk menu turn on harware mouse then exit the game every time you start up the game open sk menu when you close it the mouse should stay hope this helps someone.


There does appear to be something profoundly wrong with the game’s handling of the mouse cursor. You may not be able to see this, but what’s actually happening is that when you move the mouse cursor it flickers on and off multiple times per screen refresh.

I will have to look into that. It’s not related to Special K’s “cursor hide” feature at all, though enabling the hardware cursor in Special K’s control panel can definitely help fix the problem the game is having.

Weird well my monitors refresh rate is 59 dont know if that helps love the mod makes the game playble for me thanks.

The problem should now be fixed:

dxgi.7z (6.3 MB)

Hey tried it worked at first but when i turned hardware mouse off it broke every thing now i cant use mouse in sk menu either, turning hardware mouse back on kinda works in sk menu but i can really click on anything as it seems to be stuck on the middle of the screen.

Managed to get it working again when i turned off auto hide and kept the hardware mouse on but i dont have to open sk menu to get it to appear anymore some it seems the fix does kinda work.

Use these settings:

dxgi.7z (6.3 MB)

Hardware cursor is supposed to be on by default in all software anyway. The base config for this game already had a few compat hacks. You should leave the auto-hide feature on, just set it to ~1.5 seconds or so. There’s absolutely no reason for a cursor that’s completely idle to remain visible while you’re reading game dialog, lol.

Also, I should clarify. Just pay attention to the control panel, I forgot I had HDR / CPU performance monitoring stuff on in that screenshot.

These are my current settings when auto hide is on i cant see my mouse at all and i can’t change settings in sk menu anymore because the mouse won’t move. When auto hide is off i see the normal mouse cursor and it works fine except in the sk menu where it still refuse to move from the middle of the screen.

;NOTE0=Auto-hide the cursor after 1.5 seconds of idle because the game’s only hiding/unhiding in response to gamepad input

Probably because you have fullscreen mode enabled in game. You should be using borderless window. The game doesn’t handle fullscreen correctly.

im not playing fullscreen im playing windowed.