Metro 2033/Last light issue

Alright, so has anybody managed to get the cursor moving in both of these games when trying to use the special K ui? I’ve tried windowed mode, no luck. I’m just killing to see HDR in that game!

However I did discover one fix if anyone is interested, if you notice when SK is active, a lot of objects in game glitch out and disappear. The fix is to disable tessellation.

Edit: using a controller lets me navigate through the UI, but can’t use the controller on the widget to activate HDR, specifically for Kaldaien here: is there a way to get controller input support on the widgets? And better yet, could HDR have its own dropdown menu in the UI instead of a widget?

You should add your discovery to https://www.pcgamingwiki.com/wiki/List_of_games_compatible_with_Special_K

Good idea! I’ll get onto it now

There’s an option called ‘Unrestrict Mouse Cursor’ in the Window Management Settings that may apply here.

Usually Special K can detect when a game defines a ‘clipping rectangle’ so small that the mouse cursor can never move and will disable that. It’s used by bad ports that don’t know the correct way to implement mouselook without letting the mouse cursor wander off into other application windows :stuck_out_tongue:

Horizon: Zero Dawn comes to mind as one game that has this problem, I haven’t automatically turned on the Unrestrict Cursor option for it and that makes the UI difficult to use without keyboard / gamepad.




  1. Controller input is already supported on widgets:
  • Hold the X or Square button then LB/RB or L1/R1 to cycle through widgets; navigate with the D-Pad when you have a widget focused.

  1. How would a drop-down menu make this any easier? That’s a very weird way of inputting all the stuff that the HDR widget does.

When in keyboard-input mode (press Caps Lock), that same widget selector menu can be accessed by pressing and holding Ctrl and using Tab.

  • Use the WASD / Arrow Keys to navigate and Enter to activate.

If you need to, you can access a widget’s right-click menu by double-tapping Enter or A / Cross on a gamepad.

A bit related, but I discovered that the “Keep Inside Window” option doesn’t seem to work for The Outer Worlds. Don’t know if it ever worked, but whenever a menu is opened, the mouse is allowed to go outside of the game window >_<

It only works when the game has keyboard focus. If keyboard focus is stolen by something, then the mouse will be allowed to leave the window.

If you have the option to enable ‘Continue Rendering’, then gamepad input works even when a completely different application is actually focused. That allows you to use keyboard/mouse to work in an application on one monitor and the game another and it’s as though you have a computer and a game console :slight_smile:

Mhm, it’s weird… I think it’s broken in that game somehow as I find my cursor constantly be allowed to move outside. I was in combat moving around with KB+M when suddenly the cursor was allowed to leave the window.

Actually making the game lose focus and then clicking back in on it reapplied the lock.

It feels like whenever I open a menu in that game something happens that disables the cursor lock, and it isn’t reapplied until I actually unfocus the window and focus it back or something…

What a weird one.