Kingdoms of Amalur Re-reckoning

No, I cannot fix this :frowning:

A lot of JRPGs have the same problem. I wish I had a solution, but drawing ludicrous amounts of geometry in the wrong order is something only PowerVR GPUs are good at :slight_smile:

The format of these textures actually does not match.

The source textures are all missing the 4x4, 2x2 and 1x1 LODs. When you create the .dds, you need to remove those LODs or the dimensions change and it creates undefined behavior.

As long as you keep the number of LODs the same, everything should work

Interesting. I think this could be the reason why my texture mod doesn’t seem to work, or some works and some doesn’t.

How about upscaled textures? They often have log(N) times more LODs than the original. I guess I will have to wait for your workaround. Or one thing I can do is to remove the last log(N) LODs of the upscaled textures so they will have the same number.

Edit: Its working :smiley: Really hope that you can help me fix the texture dumping problem in the latest version with Trail of Cold Steel games, so that I can play and extract/upscale at the same time without swapping SK versions.

Call me stupid but how can I fix this if the source is the problem. I edit these texture in photoshop and export them using Intel Texture Works. Afaik there is no option to select the number of LOD.


@MyName can you describe how you got it working?

I’m not actually familiar with any artist tools, sadly.

But LODs are “Mip Maps”. My guess is there’s some kind of drop-down where “Auto Generate” is that will let you select the number of LODs to generate.

By default it generates all of the LODs from highest resolution down to 1x1, but that’s not what you want here. You want to stop at the 8x8 LOD.


I wrote python scripts to read the upscaled dds files, create a new dds container and then add the lods until the count matches the source dds.

However, I am struggling with BC7 until I can find some information about reading the correct header and extract the LODs correctly.

Edit: In texconv / texconvgui, you can set Mip level manually, so you can set it to the correct amount of mipmaps. I don’t know how to read the number of mipmaps from a dds file though. It is possible for some formats but more recent games use BC7 which I don’t know tools that can read.


Edit: worked it out just now

Use this option when importing a dumped texture into PS

Just double click the layer after importing to seperate into mipmaps
You may have to do this again because the plugin is glitchy
And you will see how many LODs/Mipmaps are contained in the dumped texture, it’s all seperated into layers. Mip0 of course being your base resolution.

Of course, you need to maintain the texture size per mipmap for injected - i suggest importing your injected version with autogenerated mipmaps in another document, and comparing to the dumped version’s mipmap layers - delete any additional mipmaps vs the dumped version. When saving with Intel’s export tools, use the “from layers” option and it will read the layers properly :slight_smile:

You may have to do this again because the plugin is glitchy

I never bothered to get into texture modding because of stupid stuff like that… In terms of widespread and efficient support for texture modding, there never seems to be any. Outdated or extremely old and buggy plugins seems to rule the day still…

A bit more info for you.

You can use this tool to convert your input image/s (it works in batch!) to dds. A bit buggy on the GUI, but works well for me.

Just select mipmap to the level that you need. (For example, if your input dds has 4 levels, then set it to 4 for the new dds).

Thanks for the help people. Sorry for the late reply, I’ve been very busy with other work.

So according to that image of yours 8x8 is level 3. Does that correspond to the three biggest layers in the .dds file? Should I keep Mip0-2 and delete the rest?


This is only necessary when the mip-maps aren’t being loaded into separate layers right?

The extracted .dds goes to Mip8 and starts at 0, that means 9 mipmaps right? I tried that and it still didn’t work, in fact it makes the game crash to loading with an error about shaders.

Holy moly this actually worked. So basically I have to :

  1. open the .dds in Photoshop and load the min-maps into separate layers as GPUnity said.
  2. Remember the number of min-maps.
  3. Delete all the min-maps except the largest one.
  4. Edit the texture.
  5. Save as .tga
  6. Use this tool to export it again setting the number of min-maps equal to what it was when I opened it. Also for DXT1 I have to use the BC1_UNIFORM format or else the app will crash.

At least now the eddited texture shows up in the list and the reload texture function also works :slight_smile:

I know man, the amount of hoops you have to jump through to make a simple texture edit is really disheartening. Almost every game has its own problem that you have to spend days on to find a workaround. Being a modder requires you to be software engineer, data analyst and graphical designer lmao. Funnily enough Shadow of the Tomb Raider, which is light years ahead of this game graphically, was the easiest game to mod I found.

I believe Kal means 8x8 is the minimum mipmap resolution the game accepts. You last mipmap layer (mip8) is 1x1, and it doubles the res (vertically and horizontally) from there - mip7=2x2, mip6=4x4, mip5=8x8
So you would have to delete the top three layers, so that mip5 (8x8) becomes the smallest mipmap/LOD.

Yes, which is what happened in my case.

The worst offender in my experience is Arkham Asylum, simply because the game caps out at 2k resolution and i want to improve the texture resolution. You can push character textures to 4k, but environment textures are limited to 2k, push the resolution and your game will crash. The best workaround i’ve found is to just do 1:2 textures, aka 2048x4096 as it’s within the engine limitations. Even Knight is limited to 2k resolution, they just stitch character models with even more groups of textures than before to push the texture density further.

Hey guys I’m running into this issue after freshly installing Special-K

I tried whitelisting the dir, and moving the special-k files to the directory. Ran the tool as admin, but still seem to be running into this issue. Any ideas?

That’s a weird assertion to trigger.

Nonetheless, turn off the Sleepless Render Thread option. It wasn’t supposed to be on by default.

So I set SleeplessRenderThread=false in the SpecialK.ini which self created in:

Documents\My Mods\SpecialK\Profiles\koa.exe

I also tried deleting these and letting the program remake them.

I’m also running the GOG version of the game, not sure if that makes a difference.

When I changed the SleeplessRenderThread=false, the error went away. But now when I do ctr+shift+backspace I get CTD :frowning:

Sleepless Window Thread, sorry. Not Render Thread.

New patch came and removed debug symbols… Not improvements to performance yet. I reported your findings almost a week ago now hopefully they are working on it.

That’s unfortunate… I almost hoped for some peoples sake that in addition to debug symbols, the build itself was was maybe not compiler optimized :slight_smile:

Hello everyone. First time using this app along with first time posting. I’ve attempted to inject a mod into KOA using Special K and ran into a problem. I posted what is below on the creator of the mod Nexus page and he directed me here.

"So I’m having some major problems with this. I’ve DL’d the Special K v0.11.0.48. After this I’ll go step by step and see if any of you can detect my issue.

Rig is a laptop i7-7700HQ, 16gb ram, Nvidia GTX 1060 6gb - displaying on 4k tv.

  1. Started Special K, selected Global Injection and hit run.
  2. Started KOA Rec and then exited the game and Special K
  3. Found folder path: Documents/My Mods/SpecialK/Profiles/Kingdoms of Amalur Re-Reckoning
  4. DL’d the Mod, then dropped the file SK_Res into the KOA folder shown in path above
  5. Start Special K again, start Global Injection service again, click on the Steam Tab and select KOA and then hit the start icon…
  6. Steam start up box(grey box you get when you launch a steam game flashes) and it looks to be starting then does nothing. I try hitting the icon to start in Special K again and at the bottom the message “game is already running” is shown. Task Manager shows a Steam Client with KOA is running but it is not.

I do have 2 drives in my laptop, C:\ and D:. Steam is installed along with all my games in the D:\ folder along with Special K, so I don’t know if this needs to be installed directly to C:\ but I’ve never had issues running any other mods out there.

Any advice or suggestions would be much appreciated. First time Special K user so not being able to load means I miss out on any mods utilizing this injector which is what has me bummed, I mean boobs are great but really not having this tool work is the real issue."

One thing I forgot to mention. If I then go back to “Global Injection” in Special K and stop the service from running and then go back to the steam tab and launch KOA, it launches with no issues.