Installation of Special K

Good thread to post the official installation instructions (dummy-proof) for Special K, because even I need some clarifying directions when it comes to manual installation of things.

  • Still install as usual? (Extract all files into the game directory)?
  • Install to %USERPROFILE%\Documents\My Mods folder?

Basically SKIF supports running from whatever. Technically I believe SKIM does as well, but for maximum compatibility it needs to be put in the Documents\My Mods\SpecialK folder.

@Aemony - Can you give me dummy proof instructions, because I’m either a brainlet right now, or I am missing 1 critical step for it to show up in-game. Also, I think I should provide the details here:

  • Documents\My Mods\Special K (it’s labeled as “Special K” with the space.
  • I run it and it opens up a window that does it’s thing and then closes. Nothing in the taskbar or anything else.
  • I run the game and Special K does not hook into it either.
  • I have also renamed the folder to “SpecialK” like old installs (in my Brainlet attempt to try something small but potentially crucial.)
  • Trying to run this for Final Fantasy XV (Just to test the new version, maybe I should try another game?)
  • Tried with The Witcher 3 as well… so I’m very much doing something incorrect.

I’m not sure how it hooks into the game without some .ini pointing it to the executable or something. I’m just feeling quite dumb lol.

What all is needed from a user in order to make sure Special K runs as intended?

Ah, okay. My bad.

I think you might possibly be hitting this issue?

I just woke up, but I might be able to test the situation out and write a functional step-by-step guide later today.

Okay, so here’s a short installation guide:

  1. Download the Special K archive and extract it to a place of your choice.

  2. Launch SKIF that resides in the folder you extracted to. You can run it either with or without the Steam client running.

  3. Through SKIF, you can launch the global injector and it will automatically initialize Special K in all processes that matches its whitelist (configurable through SKIF), but which basically defaults to all processes launched from a location that resides under a SteamApps folder.

    • Note, global injection remains running even if SKIF is closed so be sure to stop global injection if you don’t want it running in the background.

Edit: Removed all appmanifest related steps as the new version of SKIF doesn’t need it.

Edit 2: Pointed the download link to the general-purpose link found on top of the page. Hopefully that archive will always point to the latest version.


hi, new here. I launch Skif.exe but it closes without any prompt

Have you downloaded the archive called linked in my previous post? It should have that issue fixed.

There’s an older variant called where that issue was present.

yes downloaded that version. Already tried disabling geforce experience and Afterburner rivatuner OSD. It still closes automatically

I actually created the appmanifest.acf file for SK with the last version, but I wasn’t sure how SKIF wanted to read it, and I didn’t manage to get it working at that time either (I placed it in the Steam\Steamapps folder along with the rest of the appmanifests).

Thanks @Aemony!! - The new SKIF opened up and ran exactly as intended :slight_smile:

@Ahmlet - I have just had success with extracting the files to a folder and THEN running SKIF:

I ran it without admin permissions, if that helps.

Like this? it still closes

If you use Windows 10, when you download the Special K file, do you “UNBLOCK” the file first before touching it?

SKIF closes on my system too without any prompt

It doesn`t appear unblock option

Any redist neccesary for this to work, maybe I`m missing one

@Ahmlet | @ZazikWorld,

Please download and install this “All-In-One” file for Visual C++, then try SKIF again:

Still closes

May I suggest trying other options like restarting the computer, making sure your AV isn’t doing stuff behind the scenes, deleting and redownloading the NEW file, etc.

Nothing helps

Any anti virus solution going on that just blocks the executable?

Not all of them prompt which makes it a problem when you want to check so that even Defender didn’t have a bit of a fit and acted up and restricted the file from running.

yes its weird, like something block the launch. I got no AV, currently