Hooking to flight simulator

Please accept my lack of knowledge first of all. I am not as advanced as everyone in here ( I am sure!)

SO, I have followed the guides to hook SKIF to Microsoft flight simulator. For the life of me it just will not hook to it?! My white list in the global folder shows as this:-

\ \FlightSimulator.exe
\ \WindowsApps
\ \Program Files\ \WindowsApps

I start the services, all green. SKIF starts fine. Services start fine. I start the game. Nothing.
Nothing hooking at all. What am I missing?

PS this is the Microsoft store edition.

Do you run Flight Sim as an administrator, perhaps? That would prevent Special K from hooking it.

You should also only need “FlightSimulator” in the whitelist, and nothing else. The other lines technically would enable Special K to also hook other regular apps, which might on rare occasions introduce compatibility issues.

I have also tried with just flightsimulator.exe in the whitelist too, same result.
I have not touched the flightsimulator exe file, so I do not believe it is running as admin, no.

Check if you have a profile folder under \Documents\My Mods\SpecialK\Profiles\ called FlightSimulator.exe or something similar, and if there’s any logs in that one. If so, please upload them here.

If there aren’t, then it’s likely that something is preventing Special K from hooking the game – either elevation or some security suite.

You can check if the game process is running elevated by opening Task Manager while the game is running, and navigating to the Details tab. Then right click on a column header, click on “Select columns” and tick the “Elevated” column (it’s almost at the bottom). Then you can locate FlightSimulator.exe in the table and check the Elevated column if it says “Yes” or “No”.

If it says “Yes”, then the game is running elevated as an administrator. If it says “No”, and there’s no logs in the documents folder, then your security suite might be blocking Special K’s injection.

So, I do not have any logs in a profile. Zero.

I loaded the game and checked and it is not running elevated.

The only security suite I have running (don’t laugh) is windows 10 built in virus software?

Is there anything else I can try? I’m desperate to get this working.

Just a further update:-

I tried another game. Cities skylines.
The game is located in C:\Games and the exe is simply cities.exe

So, I started SKIF, added cities.exe to the whitelist, and saved and started the services. Both green.
Started the game, and nothing, no hook?

I also notice, that, when I close SKIF and re-open it, the whitelist has been wiped, there is nothing in the box, like its not saving it?

Have you forgotten to click on “save changes” below the whitelist window to actually save the changes to the local file?

If you haven’t forgotten, try editing the file manually instead. It’s located at \Document\My Mods\Special K\Global\whitelist.ini

Create the file if it does not exist (it’s just a regular text file ending with .ini instead of .txt)

I do not even have a global folder, should there be one there?

Also, yes I click save. Each time

Yes, it sounds as if SKIF fails to create them. Probably due to something preventing its creation.

Try and create them manually.

Also, can you try launching a proper Steam game to verify that SKIF actually is able to create profiles for games?

So, I manually created a global folder and placed a whitelist.ini file in there.

I also launched CIV VI from steam, and it hooked to SKIF first time. But, it did not create a profile folder when I exited the game.

Still can’t connect to any game outside of Steam…

What could be blocking it?

Security suites are the typical issues, but there’s also been instances where OneDrive can prevent it.

  • Check if you have Controlled folder access enabled in Windows, and if you do whitelist both SKIF and the game executable for that protection (or disable it entirely if you can’t whitelist them).

  • Check if OneDrive is configured for the Documents folder and if “Save space and download files as you use them” (aka the Files On-Demand) feature is enabled, as this can also conflict. If so, either disable that Files On-Demand feature, or disable cloud sync entirely for the Documents folder.

  • Check any other security suite you might have and whitelist SKIF and the game executables in that protection.

BitDefender’s “Advanced Threat Defense” (previously ‘Active Threat Control’) is an example of a third-party security module that’s often caused issues for Special K. It requires, like a few others, whitelists to be made for SKIF and the game executables for Special K to function properly.

I figured it out. I manually created the whitelist.ini file. I manually created the profile for the game. and it turns out, that steam MUST be running, even if it is a non steam game…Now it hooks to Flightsim.