Game compatibility issues that popped up in versions after v22.5.30 (and some that already existed)

I’ve had numerous issues with Special K since I upgraded to v22.8.18 which have persisted in the latest v22.9.5 and v22.9.6 versions.

These issues don’t occur in v22.5.30. I have both versions on my drive and can switch between them. I check the About page to verify the version I’m using.

Hitman 3

When loading Hitman 3, it crashes before the intro video plays. I hear that Metal Gear Solid sound right before it crashes. It was working fine in v22.5.30. One reason I use Special K in this game is for screenshots. I cannot take screenshots of Hitman 3 without them turning gray if Special K isn’t there.

If I delete the Hitman 3 profile for Special K, it loads just fine but crashes as soon as I enable scRGB HDR mode.

[FIXED] Magicka 2

There’s no HDR option in Magicka 2 anymore. It was working fine in v22.5.30.

Solasta

ReShade v5.3.0 doesn’t load up, but it does load with v22.5.30.

I’ve never gotten ReShade to work through Special K itself. I have ReShade being loaded from the game’s EXE finding the ReShade DLL.

Games load up at the wrong resolution (this issue also exists in v22.5.30)

Not all games are capable of 4K 120fps, so I will lower those games to 1080p or 1440p in fullscreen mode.

When starting Special K in these games (The Ascent, Hitman 3, Achilles: Legends Untold, and some others) I get letter-boxing on the right and bottom of the screen. So if I’m at 1080p, the game window takes up a quarter of the screen rather than stretching to fill the whole screen.

My workaround is going to the graphics settings and changing the resolution, confirming the change, then going back in the menu and changing it back; although, this is pretty annoying to do for each game each time. It’s most problematic in games that support ray tracing because I have to run those at a lower res. Even DLSS can’t save me.

Streets of Rage 4 (only tested in v22.9.6)

This is another resolution issue. The game choose the fullscreen resolution for you. When using Special K, it runs at a much lower resolution and everything is very pixelated.

Spyro Reignited Trilogy (this issue also exists in v22.5.30)

When loading the game, it’ll suddenly minimize and any attempt to bring the game back causes it to minimize again. Once it loads the game, everything’s fine, but before that, I get in this weird minimize loop.

The Ascent (this issue also exists in v22.5.30)

[ALT][TAB] in crashes the game. Also, the game will randomly crash when online. I’m assuming it’s for the same reason as why it crashes when I [ALT][TAB].

Trine 4 (this issue also exists in v22.5.30)

Crashes when loading. I think there’s an error that displays.

I’ve tried a bunch of my games with Special K and don’t remember every issue I’ve had, but I’ll be sure to add more if I see them.

try using borderless instead of fullscreen

and set the resolution you want using sk’s display menu

for reference-
image

so basically go to sk’s display menu at the top in the sk cp (you can bring up the sk cp menu with ctrl shift backspace), select your monitor, set the resolution you want, and restart the game.

setting the resolution from sk’s display menu makes your desktop and game resolution match temporarily (your desktop resolution would revert back to your native resolution automatically for you on game exit)

you’re running that game on fullscreen, right ? if so, try it on borderless

also, try your games with the latest nightly build of sk from the discord

1 Like

Borderless window fixed it in Spyro, but it causes issues with The Ascent. The menu was fine, but when I started the game, the loading screen and the game were stretching back to my native res for some reason, but since my monitor’s res was lower, it was stretching into other displays.

hm did you try setting the resolution in sk’s display menu for the ascent so that your desktop and game res matched ?

as noted earlier, on game exit your desktop res should automatically revert back to the native res you had (and next time you launch the game, it’ll automatically pick and set the res you had chosen from the sk cp menu)

also, i suggest trying the following in your specialk.ini - at least for your d3d11 and d3d12 games

[Display.Output]
ForceWindowed=true
Borderless=true
Fullscreen=true

[Window.System]
RenderInBackground=true

or this-

[Display.Output]
ForceWindowed=true
Borderless=true
Center=true

[Window.System]
RenderInBackground=true

and yeah make sure that you’re playing at native resolution in borderless with sk if possible - or if you want to use a different resolution from native, try setting that resolution from sk’s display menu from the sk cp. you might need to restart the game after that also

Tried that, didn’t fix Magicka 2 which doesn’t show anything in the HDR menu anymore.

I removed those settings and tried again.

Same issue occurred when trying to play Last Call BBS. But that issue went away after loading the old version of SK, enabling HDR, then loading the new version again.

I see what’s going on. Magicka 2 worked fine if I loaded from SK, but not from the global injector. Maybe something goes wonky if I use the global injector?

Welp, it works with the global injector now too! No clue why it didn’t work, but loading the old version and then the new version fixed it.