Framepacing issue on NFS Heat (momentary stutter)

Hey guys! I just started to play NFS Heat (via Steam Play). I’m using the half refresh rate technique (Presentation Interval = 2). Unfortunately, the game doesn’t seem to like SpecialK very much. The framepacing seems very uneven for some reason. I’m playing at 30fps and there are small stutters here and there. Is there a fix for this? The game does open a mini version of Origin when I launch it, can that be the culprit? Mouse doesn’t seem work with the SpeicalK interface so I was forced to change values in the INI.

Imgur

Imgur

Any help would be greatly appreciated.

Try using flip model instead.

The half-refresh swap interval trick generally doesn’t work with flip model.

Use Interval=1, Buffers=4, DeviceLatency=5, Waitable=On

I don’t know if you even have my framerate limiter turned on going by the screenshots you showed.


EDIT: No, I can tell now you don’t have my framerate limiter turned on. If you did, the target interval would be 33.3 ms.

Turn the framerate limit on or none of this is going to matter, that’s where all of SK’s magic is :stuck_out_tongue:

Thank you for the help. :slight_smile:

Unfortunately, nothing seems to be working for me. I can’t interact with the UI and framerate limiter doesn’t seem to work with this game. I think it’s probably due to Origin. Frame times are still extremely erratic.

I don’t have this issue with any other game on Steam. This game seems to be an exception.

No matter what I do, I can’t seem to stabilise the frametimes. The lock isn’t working.

You need to check the framerate limit box
image

1 Like

I know but the UI isn’t working. Changing it in the INI doesn’t affect it too.

Sounds like you should just cut your losses :-\ That’s even more broken than most of the games I regularly deal with.

1 Like

Yeah, sadly. :frowning:

Thanks anyway.

I even managed to turn on the limiter, but to no avail. Guess I’ll give up now, lol.

You’re running in fullscreen mode. Don’t do that.

Use flip model borderless, THEN turn the limiter on.