Final Fantasy VIII Remasterd

Hi
I’ve been trying to use the Special K to fix the Final Fantasy VIII remastered frame rate problem. I downloaded the 0.10.3.7 version from: https://github.com/Kaldaien/SpecialK/releases/tag/sk_0_10_2 , did a manual local instalation (copied the SpecialK32.pdb and SpecialK32.dll to the game folder and renamed the dll to OpenGL32.dll), but when I try running the game I get an error message saying:The procedure entry point wglGetProcAddress could not be located in the dynamic vehicle library Final Fantasy VIII Remastered\FFVIII_EFIGS.dll.

When I delete the specialK files from the game folder the games starts normaly again, but whenever I try using SpecialL’s file I get this error message.
Any idea how to fix this?

--------------------------------------------Edit---------------------------------------------------
I downloaded the SK_0_10_2_1.7z version and now the games runs propely, by for some reason I can’t open the Control Panel. Tryed Ctrl+Shift+backspace, Ctrl+Shift+Tab, and none opened the control panel

That’s weird, wglGetProcAddress (...) should be in gdi32.dll or OpenGL32.dll, not whatever DLL that is.

You’re probably better off using global injection. The download link at the top of the forum is way quicker than whatever you’re using that 2-year old version of SK for :slight_smile:

1 Like

Thx for the help Kaldaien. I’ve downloaded the SK from the top of the forum and its working now. For some reason if play the game without limiting the framerate to 30 the game runs at sped up rate. I think thats because the menu are at originaly 60fps, and the worldmap and lvl navigation are on 30fps (for some reason Oo, seriously, who even developed this trash remaster?), so when I don’t limit the framerate the game runs at 60fps all the time (making anything outside the menu 2x speed), but I turned on fps limit to 30fps and the game runs perfectly now (with the only downside of the loading and saving bar filling at 1/2 speed).

Well, I tweaked a little more with the SK, turned off the Sleepless Window Thread (which I turned on because the Fix to the frame rate issues with ff8 remastered I was following said this option should be turned on) and now the game runs perfectly, no need to cap frame rates, no speeding up, no low frame rates shenanigans of the original Steam version. I think the Sleepless Window Thread only need to be on with the older versions of the SK, and the new version I’m using now can make the game run perfectly without it.

Hmm, that’s interesting. I tested FF8 only about a month ago or so and it definitely needed the Sleepless Window Thread to fix the game’s wonky framerate limiting. It caps at like 26 FPS or so without that turned on.

I’ll have to see what changed when I have some free time not dedicated to getting D3D12 working :slight_smile:

Maibe the fact that I tryed puting a copy of the XInput1_4.dll and renamed it XInput9_1_0.dll (as some other person suggested as a fix) has something to do with it. At first adding this Xinput file did zero diference, but maibe the SpecialK32.dll (which I renamed as OpenGL32 as instructed) is actually making use of it. I did noticed that on the SK Control Panel there is a “XInput9.1.0” next to the Input Management section, dunno if it was already supposed to display that. (actualy I barely understand how any of this works :sweat_smile:).
But as of right now the game is running smoothly, all animations run just as the original, menu is at 60fps, the main game navigation e everything else is on 30fps (as should be) and battle is at 15 fps (can’t belive thats actually what was intended by the developers).
With the Sleepless Window Thread the game stays at 60fps at all times. So main game stays aways 2x speed, which isn’t an actual problem, but battles are always 4x speed, which makes things really difficult. My earlier solution of limiting maxfps to 30 did fix the main game, but battles still were at 2x speed, and the menu at 1/2 speed (which at first didn’t bothered me at all, but soon I realized Triple triad was 1/2 speed too, which annoyed me enough to start tweaking with the SK despite not knowning what was I doing :sweat_smile: :sweat_smile: :sweat_smile:).
---------- edit --------
And, just to make it clear, the only thing I did differently from this Fix : https://steamcommunity.com/app/1026680/discussions/0/4276687120031102568/

is that I turned the Sleepless Window Thread off. Also I don’t need any auto-clicker to keep the frame rate working properly.

Also, I’m fairly sure the idea of taking a copie of the XInput file from the windows folder came from some1 with the same username as you in a comments section on steam xD