EGS Games Are Not Launching After 22.1.4

Some of my EGS games are failing to launch if I use any version of SK newer than 22.1.4

As soon as I drop in, for example, games like Control, HITMAN 3, Crysis Remastered, refuse to launch.

No configuration files are created either under %USERPROFILE%\Documents\SpecialK\Profiles, so I have no logs to submit for troubleshooting.

I’ve tried the latest stable release (22.1.18) from Discord as well and I am experiencing the same issue.

Any help with what’s going on with this would be appreciated, also if other people are experiencing this same issue.

EDIT: Supposed to be 22.1.4, not 21.1.4

Thanks for reporting this. I believe the problem is now fixed (, it’s very likely those games are not DPI aware and part of SK’s startup procedure is to patch games that aren’t DPI aware and restart. But restarting didn’t work correctly for EGS games.

Hi Kal, thanks for replying.

Unfortunately, at least on my end, I don’t think it’s fixed.

22.1.4 is still the latest one that works for me. I’ve tested HITMAN 3, Control, and RDR2, none of them work if it’s still not 22.1.4.

Even using the latest version of SKIF seems to have trouble launching the global injection service whenever I use the latest binaries (it gets stuck on “Starting…”).

Also tried local installs of copy + pasting + renaming SpecialK64.dll into the game’s folder as dxgi.dll, and those methods don’t work either.

I have no idea if I’m the only one experiencing this.

EDIT: Solved the SKIF issue; dumb mistake on my part. But I’m still experiencing the main issue of binaries later than 22.1.4 not working for EGS games.

Can you grab 22.1.23 off of Discord and let me know if things have improved?

In fact, EGS-related stuff is in active development at the moment and you’re more likely to get support if you stop by the #support channel and chat with us there.