Discord Closes The Game When Streaming

Everytime I try to stream to discord a game with Special K installed, it closes the game entirely. Is there something in the settings that I’m missing or does Special K not work with discord at all?

I haven’t experienced this issue, and i’ve used Discord streaming with SK a couple of times, so i don’t know what’s up on your end.

If i can spare the time tomorrow, i’ll see if the latest version of SK works fine for me and get back to you. For now, i suggest closing anything including overlays and other recording software, and giving it another go.

I have FAR version 0.7.0.23 for Nier installed. Once I booted the menu screen I alt-tabbed to the discord screen to start streaming in a vc, but when I click the game screen it immediately closes the game.

Also want to note that I tried to stream Yakuza 0 which was using Special K through the SK Steam App. When I started streaming it and clicked back to the gamescreen, the MGS alert sound played and closed Yakuza 0

What’s the connection between Discord and streaming BTW? I thought that at most, Discord was a simple overlay.

I’ve tested Yakuza 0 on its own recently and it’s “fine” (ignoring all the issues I originally patched for it).


I’d suggest using the version of Special K linked at the top of the forums (0.11.0.48) though, rather than the one that SKIM.exe installs for FAR ( hell if I know, it’s > 3 years old :stuck_out_tongue: ).

You can stream games over VCs which I usually do for my friend group.

Also thanks for the suggestion, I’ll look into that in a bit

Extracted the newer files into the directory of the steam app version of SK and launched Yakuza 0 as a test. Ended up crashing once streaming again.

I am going to need to see some logs to diagnose this any further. You should be able to just drag and drop them into a forum post, if not pastebin.com is preferred.

Which logs should I share?

logs/crash/<timestamp>/{crash|SpecialK|modules}.log

Put in the logs from crash.log dxgi.log and modules.log from when I fresh installed SK to Yakuza 0 and tried streaming.

Will this suffice?

I see Riva Tuner Statistics Server but I was under the impression the newer SpecialK releases were more compatible now.

Discord is also hooking D3D but since I think this is Chromium and hardware accelerated that’s not a surprise, not sure if SpecialK’s internal blacklist covers for Discord or not though like it does for certain web browsers to not have SKIF or SKIM attempt to hook into this.

Just a few observations with DiscordHook64.dll and RTSSHooks64.dll potentially a issue here with the way some of these hook into Direct3D but these would also be used for the actual streaming process if you’re using Rivatuner for the recording so it can’t just be stopped.

Wonder if SKIM and a entry for the Discord application for the blacklist would work.
RTSS/Afterburner would already be in there by default.

EDIT: Bunch of override errors too around where RTSS tries to unhook.
DXGI_ERROR_INVALID_CALL and DXGI_ERROR_NOT_CURRENTLY_AVAILABLE

Back buffer and window state it seems repeating a bit before the modules.log starts.
Silently crashing perhaps, SpecialK uses a sound cue for this.

EDIT: Also 456.55 and the newer 456.71 drivers from NVIDIA have a few fixes over 456.38 but that’s secondary.

Adaptive and G-Sync fixes but it’s for black screen errors not software crashes.
(Some game specific fixes and some security fixes but also nothing that’s part of this issue specifically.)

If I remember it correctly, Discord technically doesn’t require its overlay enabled to stream a game. At least I believe I have streamed a game over Discord without acruaöly having the overlay enabled.

I do actually have overlay disabled for almost all the games I play, especially ones where I use SpecialK

Ideally, you’d include the first half of dxgi.log too :slight_smile: There’s information about the SwapChain setup and your GPU that is missing.

That said, ForceWindowed=true would probably prevent these problems.

oops, heres the dxgi.log

Also I tried ForceWindowed on the display settings of SpecialK and still get a crash once streaming