Dark Souls 3 Fullscreen issue

So i have three games installed now and 2 natively support HDR except ds3. So i got this mod. Installed Local 64 bit dll. I launched game. Activated HDR widget. Toggled HDR. Quit the game. Restarted. HDR Working perfectly but the screen is windowed and displaying on one fourth of screen. I have 4k display and i play at 2K. So i delete everything. Switched internal resolution to 4k and now the game shows on all of screen however it is still somekind of borderless windows setting. But my system cannot run this game at 4k60, so i play in 1440p but i want the display output to scale to all of screen. Now we have dxgi.ini and soulsunsqueezed.ini (which automatically gets added). And i have been at it for hours but i just cant get it to run at all of screen. I want either fullscreen or all of screen option.

HDR retrofit is only available in flip model, which usually requires a borderless window that matches the native resolution of the monitor.

What you can try to do is basically the following:

  1. Configure the game to run in window/borderless mode (if it supports that).
  2. Configure the game to run in 1440p windowed/borderless mode.
  3. Open SK’s control panel and expand the “Display” menu on the top of the SK window titlebar, then select Borderless. Open the control panel again and select Borderless Fullscreen. If everything works fine then the 1440p resolution should be expanded to cover the whole monitor.
  4. Restart the game to see if the changes are retained.
  5. Expand the Direct3D 11 Settings > “SwapChain Management” section of SK’s control panel and tick the “Use Flip Model Presentation” checkbox.
  6. Restart the game to see if the changes are retained.
  7. Finally if everything works fine, enable the HDR retrofit and restart the game.