Cyberpunk 2077 losing mouse input + resolution question

Hello, I already posted this in the megathread but I think it belongs here.

When using Special K with Cyberpunk I’m running into the issue that the mouse stops working after alt tabbing sometimes.

SK Version: the one from SK_Cyberpunk2077.7z
What I tried so far: launching cyberpunk from the .exe with steam_appid.txt in the folder

Is there some way to fix this that I’m missing?

And I don’t know if this is in the scope of SK, but I’m trying to run the game in 2560x1280 on a 2560x1440 Monitor and the game decides to just upscale that to 16:9 for some reason.

Setting the Desktop resolution to 2560x1280 works, but I was wondering if there is a way to set this up with SKs max resolution.

Limiting works, but the game still decides to upscale to fullscreen.

What I tried:
Nvidia CP: Disable Scaling.
Set the game to fullscreen.
Set Max Resolution overwrite to 2560x1280 - this limits the ingame menu to only this resolution.
Restart game.

Result: 2560x1280 Resolution streched to 16:9

any help is appreciated

Wonder how the game detects and scales the resolution, a separate choice of aspect ratio would be helpful but at worst if it detects the desktop or EDID resolution maximum it’d be stretching out 2560x1440 instead.

There’s a newer 64-bit SpecialK .dll in the latest posts from Kaldaien in the big topic but I think this mostly fixes specific problems with the Steam overlay and some further HDR tweaking so nothing that would help here and adjusting the display resolution and min and max might not work without a way to force a aspect ratio either.

SpecialK and the Cyber 2077 archive probably has that DXGI.ini file too with a ton of overrides in it, borderless or windowed perhaps would be best as we’re not using the native resolution unless you set the desktop one to this first.

So either disabling some of these like swap chain wait, flip model if set and getting control over resolution changes and window states or setting a toggle via HRC so you can swap between 2560x1080 and 2560x1440 with a button press or combination without losing some of these enhancements.

For mouse input I would just keep testing various SpecialK input options if that helps.


Hardware cursor with relative input perhaps.

Some games can be finicky with changing how they hook the input and then finding a good setup that works with SpecialK here.

At worst you might get a mouse cursor for SpecialK and it’s menu while open and another for the game cursor but the SK one should go away when the UI’s toggled off and the game input should work.

EDIT: I don’t have the game installed myself yet as I’m working on the existing backlog, also not too tech savvy with the way SpecialK works especially the D3D and DXGI setup and overrides going into very interesting enhancements much as I try to read up on and get the basics of these or the ongoing HDR additions.

Game and game engine specific issues can be a real hassle too keeping track of and finding a good combination of settings or compatibility options that work well. :slight_smile:

Saw the post in the big topic but couldn’t give a good answer, can give some general advice and opinions although some of this might be down to what the Red Engine is doing here with handling resolution detection and scaling plus unless there’s something set in the bundled DXGI.ini with all of the settings Kaldaien threw into it also how the engine is handling input think Kaldaien is also often using a gamepad but that shouldn’t conflict with mouse input it’s separate toggles for X Input and other gamepad options in the config file. :slight_smile:

EDIT: Hmm come to think of it as I don’t have one I am not sure how usable the SpecialK UI is yet with only gamepad control if at all, might still need to have mouse input to utilize it but perhaps it’s just the game input that stops responding not the SpecialK OSD and menu and then it works for that still.

1 Like

It’s a problem with the GeForce Experience Overlay, I have a fix for the problem in the latest test DLLs…

Use this:

dxgi.7z (7.6 MB)

However, for resolution scaling… I cannot help there in D3D12 at the moment :-\

Resolution scaling in D3D12 is not a good idea, anything other than native is going to put you on a weird performance path. That means if you want some weird aspect ratio or different resolution than your screen natively runs, your best bet is to change the desktop resolution.


Hello, thanks for your answers!

@Kaldaien Mouse is working now, big thanks!
I’ll work around the resolution in that case.

@JonasBeckman Thanks for the detailed answer and a possible workaround to my resolution issue.

I found it interesting that resolution scaling is different with D3D12 but I suppose with flip model enforced and a step away from BitBlt there’s a few restrictions for the advantages this does bring with input delay and render latency.

Might not be a especially great solution as a result though trying is always possible seeing how it acts but changing the desktop resolution a bit smoother might be the best compromise then.

Didn’t know that the GeForce Experience and it’s overlay can bind up the mouse cursor too.