Can't enable flip mode in Batman Enemy Within

Hello, Batman Enemy Within (d3d11) uses by default Borderless Windowed and doesn’t support Exclusive Fullscreen.

I have Gsync only enabled for fullscreen games and so I tried to enable flip mode with 3 backbuffers, but when I start the game it’s still using its borderless windowed standard mode (gsync not supported and backbuffers locked to 2).

Is it the game overriding the window settings i set in SpecialK?
I’d like to upload SpecialK.log but I can’t being a new user.

Another option I can try is forcing exclusive fullscreen with SpecialK (no flip mode). It works but the game locks the backbuffer count to 1, even if I set 2 or 3. Is 1 too low and could make the game stutter more?

The last option is, of course, enable Gsync also for windowed applications, but I’d prefer not doing so.

Nevermind. I “solved” the problem. I had the OSD enabled to display fps and frame times. I’ve just disabled it and now the game starts in flip mode and gsync works.

By the way, is it a good idea to enable the waitable swapchain too with its default value of 15? Or I’m better leaving it off?

What OSD are you referring to? Special K’s OSD has no problems with that sort of thing.

Don’t worry about the “Waitable SwapChain” option, that’s being phased out. It’ll still be an option in, but it’s simply On/Off (with no numbers to configure). That setting only affects Special K’s framerate limiter, if you haven’t turned it on (you SHOULD), it doesn’t mean anything one way or the other :slight_smile:

Yes, I’m also using the framerate limiter locked to 141fps.
Also, the waitable swapchain number to configure I was talking about is the one in the SpecialK.ini file, in the GUI is already only a on/off switch. In this case, should I just enable it and leave 15 in the .ini?

I’m referring to SpecialK OSD. If I start the game with a widget or the fps info on screen enabled, then the game won’t apply the settings I set for the window. Then, if I start the game without widget etc., the window will have the settings I apply.
It only happens in this game, anyway.