Can't display control panel

Hello guys,

I have just installed special k install manager the latest version and i have followed the install instruction perfectly. When i launch a game for example hitman or metro exodus i cant display the control panel.
Here is the profile folder of hitman https://gofile.io/d/WKVGek

Hmm from both of those examples that sounds like DirectX 12 is used which is still not fully supported such as how the on-screen display is not rendered fully in this mode, SpecialK might still work in the background but setting it up and adjusting the configuration is a bit trickier with D3D12 active.

Thanks for the help, it works now with direct x 11 enable.
I still have two issues, first one i have metro exodus crashing at launch since i have installed special k.
The second one is i dont have steam achievement enhancements when i play Hitman but i do have them when i play amensia rebirth for example.

Here is the profile folder of Metro exodus : https://gofile.io/d/0c0EZL

I can imagine that would crash… are you sure you have it using D3D11? It’s clearly running in D3D12 mode, and then weirdly creating a D3D11 device on top of the D3D12 device it created earlier.

I’d consider setting d3d11=false in the API hooks section of the control panel.


As for the Steam issue, some of these games panic when friend achievement statistics are fetched.

Browse to Documents\My Mods\SpecialK\Profiles\AppCache\ , find the directory for Hitman and then edit its SpecialK.appcache file:

[Friend.Achievements]
FetchFromServer=false

so to be clear i cant launch D3D12 games with special k enable ? That means i cant use Ray tracing or dlss ?

DLSS has nothing to do with D3D12, lazy developers are responsible for that option only being given in D3D12 mode.

RayTracing on the other hand, no… if you want Special K’s in-game UI, you can’t use RayTracing.

I still dont have achievement for hitman

here is the appcach file

[AppID_Cache.RevMap]
236870=Hitman™\retail\hitman.exe

[AppID_Cache.FwdMap]
Hitman™\retail\hitman.exe=236870

[AppID_Cache.Names]
236870=HITMAN™

[License.Info]
LastRevision=20190408

[Friend.Achievements]
FetchFromServer=false

Then just disable SteamAPI completely.

[Steam.Log]
Silent=true

Put that in SpecialK.ini for the game (easiest way to get to it is via SKIF, just hover the config file at the top when the game is selected and it’ll open the cfg.)

still not working for hitman but its ok i will deal with it.