Cannot dump textures in Nier Replicant

I would like to dump the textures in Nier Replicant but when I open the “live texture view” it is empty, even if I reload the textures.
I tried with another game and it worked immediately: the list was full of textures.
I’m using the global injector, the Special K version is The Game version is the latest one on steam, 1.22474487139.

Thank you in advance!

launch the game with Special K

open the Special K control panel menu (ctrl + shift + backspace)

uncheck d3d11 state tracker performance mode


and then you may need to restart your game

I bet the textures will show up for you in the live texture view after that and you’ll be able to dump textures

also, keep in mind that ReShade could interfere with texture injection in this game…

another thing is that this game uses staging textures rather than the normal way for uploading textures, so there’s no possibility of changing the size or format… basically if you mod/edit some texture to inject later, you’d want to save it as .dds with the same format and even same resolution as the original texture you’d be replacing for it to show up with this game.

Hello, thanks for your quick answer!
I tried to uncheck d3d11 state tracker performance mode, restarted the game but the list is still empty.
I also tried to enable/disable D3D11 deferred mode under Direct 3D 11 settings, but also without any change.

This is how it looks the control panel.

Many thanks!

it worked just fine on my end after unchecking “d3d11 state tracker performance mode” and restarting the game.

are you using a cracked version of the game ?

No, original steam game. I even did a file integrity verification just to be sure.
I’m not using any reshade or anything else.
Do I need to install some additional component perhaps? something like .net framework, visual c++ or something like that?
Or perhaps MS defender could be interfering with Special K?

no… or at least not if you ran the special k installer.

if using special k with local injection (renamed the SpecialK64.dll to dxgi.dll and placed it the game’s folder), you might need to install the visual c++ 2015-2019 x64 Redist stuff.

the Special K installer should take care of that, and I’d suggest launching the game from the Special K injection Frontend app and using global injection (just select the game from the SKIF app and then hit the launch button to launch the game with SK). also, for global injection to work, make sure to delete any special k dll files in the game’s folder i you had any there.

i just tested again also. it still works fine for me.

  1. i uninstalled nier replicant from the steam client

  2. then i deleted the game’s folder to ensure nothing was left

  3. then i reinstalled the game from the steam client

  4. then i deleted my SpecialK.ini config for the game

  5. then launched the game from the SKIF app

  6. then I opened the SK cp menu menu with ctrl + shift + backspace

  7. then I went into sk’s render mod tools and textures were missing in sk’s live textures view window as expected

  8. then I unchecked the “d3d11 state tracker performance mode” in the SK cp menu’s graphics settings section

  9. then i closed the game and relaunched it from the SKIF app again

  10. and then I went to look in sk’s live texture view window and saw textures there now as expected…

you could download the special k installer from here (or go to the download section of the forum)-

then launch the special k injection frontend app, go to the settings, and set it to “discord (updates regularly)”


then hit the update button-


or set the “check for updates” option to “on each launch” and restart the SKIF app to trigger the update if you’re not on the latest version.

you could also grab the latest installer or latest nightly-build version of special k from the special k discord.

i’m not sure what version you’re using or if updating would fix your issue, but i’d suggest updating anyway and try the special k installer along with global injection if you haven’t… plus maybe try the 10 steps i posted above.

some apps known to interfere with sk are nzxt cam, rivatuner/rtss, razer synapse, anti-virus… but windows defender should be fine i believe. i use windows defender also.

if you wanted to also use rtss alongside sk, you could try checking the “use microsoft detours api hooking” option from rtss and at least in some cases that apparently can make rtss + sk work.

Hello, after trying multiple times to disable software, antivirus and change settings on the PC, I uninstalled Special K, reinstalled it and now it works :confused:
I’m suspecting that there was some strange setting in the .ini file that created the issues I had.
“DumpOnFirstLoad=true” is also not working but well, the rest is so that’s enough for now :smiley:

Thank you so much, Gias, for your help and support, it is very appreciated!