[bug]differentk.fyi certificate missing apex domain

Tried to access this site via the apex domain, got a certificate error. Checking the certificate, it only has the DNS name of discource.differentk.fyi and not the apex domain differentk.fyi.

Thanks for reporting this – it’s been a long-standing bug that I never got around to fix, but I finally took the time to work on the server for once.

  • The additional domain has been added to the certificate, so those errors should no longer occur.
  • The server also went through a few OS upgrades, so is now up-to-date as well (which was about time as the old OS version will go out of support next month).
  • And the forum software itself was also updated to the latest version.
  • SMTP/mail notifications were solved through a temporary workaround (will be sent from my domain instead of the site domain for awhile).

I think all issues that I ran into with the upgrade should now be resolved as well, as the site seems to be functional again :smiley:

Edit the next day:
Got around to reclaiming a literal ton of space on the server as well, which may break a few images and whatnot.

Last year I moved/migrated all backups and uploads over to being stored on our CDN instead of locally on the server. Today I removed the old files that still remained on the server. In my testing all of the images and uploads works as expected, though a few less important stuff like image embeds for websites (Nvidia’s in particular) didn’t seem to migrate over, though that’s generally a minor price to pay for reducing the server space by a ton (60% of the space was reclaimed).

All in all, a good day :smiley: