Bayonetta CTD (might be RegEdit / Fullscreen Optimization related)

I don’t really know how to get any further with this, but SpecialK works great for me on any game, except those that are DX9 + 32-bit. I’m trying to play Bayonetta right now with a local SpecialK install and I haven’t enabled the FSO compatibility flag for the .exe, but quite a while back I did a bunch of RegEdit tweaks to disable Fullscreen Optimizations globally.

Is there any way to force it on for one game? I tried reverting the value in ‘Computer\HKEY_CURRENT_USER\System\GameConfigStore’, but it still crashes instantly.

I’ve also tried a global SpecialK install, but that doesn’t work either.


crash.log is just this:
"1. 09/28/2021 17:22:05.518: DebugHelper Symbol Search Path…: ;C:\Users*****\Documents\My Mods\SpecialK\

  1. 09/28/2021 17:22:05.518: Unable to load Special K Debug Symbols (‘C:\Users*****\Documents\My Mods\SpecialK\SpecialK32.pdb’), crash log will not be accurate."

ReShade seems to work fine.

Generally speaking the incompatibility of SK locally installed as D3D9.dll with FSO disabled doesn’t even create logs – that combo just tend to crash on launch without the application even starting.

That said, seems modern versions of SK might have an issue with that game or something. Half the time I launch it using local injection myself, it crashes. The other times I get into the game but the textures are broken up.

Sadly I was unable to fix either of these issues through messing with the config file myself, so this probably needs @Kaldaien’s eyes.

You might also want to try using an older version of Special K as they might offer better compatibility:

Just be aware that you should probably set Silent=true below the [Steam.Log] section of Special K since apparently there’s an issue with achievement unlocking? At least that was the case based on a random thread I found from three years ago.

I appreciate the reply! Even though there’s no easy fix other than going back to an earlier version, the info you provided is very helpful, thanks!