Assassin's Creed Valhalla

That is a possibility, but what could it be? I’ve changed a lot of settings.

Try this version:

dxgi.7z (7.6 MB)

I changed the waitable swapchain behavior. It was too aggressively trying to get rid of input latency for this game.

3 Likes

That helped, but I can still see microstutters when paning the camera. I’m very sensitive to it, always has been since the 90’s playing on crt monitors. So I know they’re there.

Whatever you did reduced the stutters though.

I will play without it for now. Still running around in Norway and the game is buttery smooth at 60 fps. Everything on highest settings except motion blur and depth of field turned off.

8700k @ 5.1ghz
4000mhz 17-17-17-32 memory
3080 Strix OC.

Ah, that’s a shame. There are things that can be done to tune Special K’s framerate limiter, but the process works best when SK’s in-game UI can actually be used to make the adjustments in real-time.

I know there should be some combination of settings that would work for you, but lack of UI support in D3D12 is unfortunately a big setback here :frowning:

Tuning the framerate limiter settings perhaps but yeah unless SpecialK periodically re-reads the ini file you’d have to exit and set new values.

Possibly macro and a key bind to re-read the file or how to say, kinda like loading a preset I suppose actually possible using that functionality to directly set a config value. :slight_smile:

Think there’s a example macro now for the swap chain and resetting something in regards to that for if you alt-tab frequently or after a few hours of the game running if it starts acting choppy. :slight_smile:

Newer NVIDIA drivers should fix a few things too seems performance is under delivering on AMD Ryzen CPU systems for some reason so that can explain stuttering but in this case it’s a Intel 8000 series and the game(s) from Ubisoft are also kinda RAM bound but a good profile at 3200 - 3600 or higher and you mitigate the worst of it. :slight_smile:

EDIT:

And then a bit more about what further NVIDIA drivers or driver branches can give.
The game itself could do with a patch or several too but how much Ubisoft will optimize well we’ll just have to see.

EDIT: All the avatars and the forum decided to use a dog one for the media embedding. Must be from the opening post or something for how it gets that. :smiley:

After waiting for updates for a long time on the various public places you uploaded updates to (Steam, Github)… it’s nice to see updates are still being made though kinda a clusterfuck to find my way here to this place.

Anyways, I thought I’d give this a shot with Assassin’s Creed Odyssey and Origins and it seems to work fine with both games, which is nice since v0.10.3 and older weren’t working. I dunno if this version messes with the asset streaming/scheduling stuff that was causing performance issues when the games are installed to an SSD though, since I have the games installed to a HDD and don’t experience that issue as a result (at least at 60FPS).


I also tried this version with Monster Hunter World but the game outright refuses to open.

With the SKIF UI program that the Download button at the top of this website downloads, Monster Hunter World will almost reach the Main Menu before it crashes out. Not sure what version is suggested for that game or if it’s even supported anymore by you (considering your past history with trying to support the game it wouldn’t surprise me if you aren’t working on compatibility with that game anymore/at the moment). the SKIF download was also incompatible with the Assassin Creed games.

Really? It should be easier than ever to find Special K now :slight_smile:

It’s just special-k.infowiki.special-k.info , gitlab.special-k.info , sk-data.special-k.info

The one place you won’t find anything Special K related is Steam, @#$% Steam :stuck_out_tongue:

Is there something I can do through the .ini file or do you have to make updates to the .dll?

No idea if you can see what the game is doing with memory but the game has a serious issue with virtual memory on my 3800x, 32 GB, 2080 Ti machine.
Spent over 30 hours playing the game where it turned into a <5 fps slideshow after 2 hours in any populated area.
The only two common factors of it happening were NPCs + time spent. And I tried everything to fix it. In the end however it seems that manually setting a page file size in Windows fixed it. Been a long time since I’ve had to do such a fix to a game. Would be interesting to know what on earth it’s doing to cause this…

Yeah some games don’t take well to a non-existent or very small page-file even if it should be using RAM, Windows itself is also a bit mixed as to how it behaves as it will attempt to page without one set so that’s part of the issue too.

Commit charge and size a bit after boot should show how much is paged and that used to be a good way to determine minimum size but later OS versions does a good job with automatic and expanding as needed.
(Usually a few hundred MB at most but then games like these will just not work unless there’s more.)

I use a fixed 4096 size (4 GB) because might as well but some games leak extensively so given time they’d run out eventually.

Clearing standby memory can also help but the Windows 10 OS builds Redstone 4 or 5 I think and newer should be better at releasing cache memory as required core issue here where it was held forever was fixed a while back though it can still be a bit slow at releasing this memory until cleared manually.
(EmptyStandbyList.exe I think is what the software I use for this is called.)

Final Fantasy XV’s another example you can use the task manager and observe how it just hits the page memory frequently. :slight_smile:

EDIT: It’s been a few years since I had a game outright crash from having a too low page size or attempting to use none even with plenty of actual RAM so at least that’s improved.
(Same with the audio issue in some games crashing above 48000 frequencies although that is often already above the 44100 sample size or lower used by most games.)

EDIT:

Something like that, now I’m curious as to how much would be used letting the game go for an hour or two while I’m fiddling with the settlement or something letting it build up a little bit.

I don’t think SpecialK affects this much but I am using the newest D3D12 .dll from that pinned topic as a replacement since it has some additional things although nothing that is outright required. :slight_smile:

Hi can any one help me please? i am trying to use special K linked at the top with valhalla but i keep getting either crash to desktop before it gets to the menu or a black screen and freeze. I know its no third party software causing the issue as i did a fresh install of windows and still same problem. It works fine with zero dawn. Thanks in advance.

Read the first sentence in this post.

You can also use the test version here:

D3D12 Missing Features - Development - Special K Discussion (differentk.fyi)

I am using the pre configured standalone release keeps crashing, I also just tried the test version and exact same issue. Thanks

Disable overlays like RTSS

@Kaldaien, brother…long time admirer of your work from the Tales series, Dragon Quest, etc.

I’ve downloaded the standalone for this game and it does wonders, kudos, but I have a dilemma. I got a LG Oled C8 and I just have a 6850k w/ a 1080ti, on the NV panel, I’ve set it @4k res but when I play, in-game its set to 1080p since I just play 60fps.

I’m having trouble enabling HDR on my tv, is there any tips u can share?? I read several articles saying enabling HDR via Windows but that is not true HDR and its still in the SDR color range, I believe. The only time I see my tv switch on HDR automatically was when I was playing @4k Fullscreen mode but my sytem can’t handle a good fps when its set to that…

I just now have it at 1080p, no limit (fps), borderless, when I switch to HDR via in game, nothing happens after confirmation, WIN HDR is OFF…

You might need to set your desktop resolution to 1080p.

This game uses the modern form of HDR, so that means it needs HDR turned on in the desktop.

You could try the latest D3D12 compatible test build of Special K, its overlay can tell you whether the game’s HDR or not.

In some cases the game doesn’t fully engage HDR until you open the display config menu after starting it.

Thanks for replying to me.
So what’s the difference of setting the in-game resolution to 1080p vs. setting it on NV panel??

So HDR needs to be ON in Windows then set On in-game to make it work…??
It seems that’s the only implementation of HDR for this game as of right now, I’m also running this Borderless, which you suggested since I’m using the standalone Special K??
On the ini file of the standalone, can I set the TargetFPS to no limit? If so, how do I do that??

Setting the desktop resolution changes the system-wide resolution, changing the in-game setting will stretch an image to fill the desktop. Usually there’s not a huge difference, but the game could be programmed to only recognize HDR when the input/output resolution is identical.

Use this and save yourself a lot of time:

dxgi.7z (differentk.fyi)

Just open the control panel and change the framerate limiter in-game. You won’t have to guess what impact it’s having on performance or be mislead by the inaccurate in-game framerate counter / imprecise RTSS graph.

The game was updated. :slight_smile:

EDIT: Where’s that changelog.

EDIT:
[URL]Assassin's Creed Valhalla - Title Update 1.0.4 | Ubisoft Discussion Forums

EDIT: Well…that could have gone worse.
And better.

EDIT: There I mostly resolved the worst of it, kept the Odin Sight emote Ubi threw in too because why not.

Hmm fixing a memory leak and VRAM leak on alt-tab. Good.
Wonder if the game remembers your helmet selection yet. Minor annoyance though.

Is there a way to turn off the GUI in the latest version? For some reason, Valhalla stutters way more with overlays from SpecialK/ReShade/etc.