Aliens vs Predator (2010) Crashes when entering a 3D scene and achievement testing

As the title says, AvP out right crashes when entering either a 3D scene or when forcing a test achievement to pop up. I tested on two different versions of SpecialK, the last version that used SKIM64 as the GUI for the injector and the most recent release from yesterday, both had the same effect. I removed all traces of the old SpecialK version before running the new one too.

I’ve tried turning off texture caching, CEGUI, Steam overlay, shut down all of the Radeon stuff in the background, essentially running completely naked and it still crashes.


I’ve tried everything I could think of so any help would be appreciated.

Hmm, I see. That’s using a significantly older SteamAPI DLL than most games.

You’re probably going to want to turn off all SteamAPI enhancements, [Steam.Log] Silent=true in the ini file.

I’ll add this to a todo list, to detect older Steamworks games so this isn’t a future problem.

Makes sense considering it uses VAC, didn’t even think about it since I disabled the overlay.

I set it to true and disabled any enhancements in the GUI while running the game, clicked start and it crashed again. Got another set of fresh logs after the crash with the Steam stuff disabled: