Age of Empires 2 Definitive Edition - anti-tamper doesn't like SK


I’ve been using Special K for a little while now and so far it’s been a great help but the Age of Empires Definitive Editions are giving me problems. All I use Special K for is forcing vsync off and exclusive fullscreen on but the anti-tamper solution AoE 1-2 DE are using really doesn’t like that.

In the case of AoE 2 DE the game gives me this message and proceeds to shut down fairly often:

“A running process may be interfering with the correct operation of AoE2 DE. This may be caused by anti-virus software, malware, game overlays, or other active processes on your PC.”

It doesn’t happen always though so at least the game is generally playable. AoE 1 DE has its anti-tamper check right when you launch the game though so a similar message will appear in the main menu and there goes my game every single time I try launching it.

I’m not an experienced Special K user so I really don’t know which feature of the app might be causing this or even if the issue can be solved or not. Any tips regarding this? So far all I could do was to notify the devs that maybe this is not the injector app their anti cheat should be looking for. Age of Empires 2 Definitive Edition - anti-tamper doesn’t like SK

Test versions of SK that’s available on the Discord server has a few changes to them that makes ‘em more compatible with anti-tamper protections, so if you’re using SK or older then I highly recommend testing one of the releases on Discord.

I tried a bunch of them in the last week or so, none of them faired better than the original stable release I was on.