AC Odyssey not working?

I don’t know if this the right place to ask but;
I have both the latest steam sk and odyssey sk low for AC odyssey but none of them work. game just freezes in splash screen.

Is there something I’m missing?
Sorry but google only brings up 2 year old topics that does not work for current steam version.

Have you set Silent=True in the SpecialK.ini? There should be two Silent=False lines that you need to replace with true. It fixes the majority of Uplay titles but not all, sadly.

1 Like

hi, thanks for the reply.
does it work on both branches?

You should just be able to download the latest Special K and use global and then it’ll pick up ACO and apply the patch directly. It does with Origins, at least. If you have the Uplay non-Steam version you can create a whitelist directory in SKIF.

I’ve got it from steam. (Both sk and ac odyssey)
made both “silent=true”. Still stuck on splash screen.

Try my config, maybe it’ll help. I can’t remember if I made any changes to it or not but Origins boots fine. I don’t have Odyssey to test on though. You can also try disabling the Uplay/Steam overlay if you haven’t already.

SpecialK.ini (4.9 KB)

Origins worked pretty well, Odyssey I had to go back to 0.10.x one of the earlier Github builds to get the game to even start reliably but that might have been fixed. Same thing in Watch_Dogs 2 and many other Ubisoft games although others just work.

Also if it’s enabled disable D3D9 in the config file for SpecialK that can also be a problem like how Far Cry 5 had a thing for calling DirectX Diagnostic (DXDiag) so it’s D3D9 and then it’s D3D11 suddenly and that gets problematic.

So that’s why D3D9 and D3D9X should be set to false.


Hour or two into the game even after it started the game would just crash though, there’s no super advanced anti cheat routines or similar so it’s not that but if you do get it to work with the latest version after toggling off Steam (The Silent=True settings) and possibly D3D9 well that’s probably why.

But it could also run just fine with the latest game update and of SpecialK which I believe is still the latest build for now. (Together with SKIF 0.7.x somewhere for launching and updating the utility.)

1 Like

dxd9 thing fixed it thanks!

Wow, I forgot all about that :slight_smile:

Yeah, all of Ubisoft’s games strangely run dxdiag at startup. They investigate all the versions of DirectX and confuse the hell out of Special K’s API detection.

Some games like doing it on exit too but I don’t know what info is used by having it as some startup check routine beyond extending startup time and complicating things.

You don’t check feature levels or criteria like needed runtimes or what not by querying the DirectX Diagnostics Utility and wherever that log is sent since that’s what it does writes it into some report when used in normal mode so you get a basic write-up of some system settings and D3D compatibility.

Pretty sure you would also query NVIDIA and AMD functionality like the version string(s) for anything like what the Frostbite engine games and a few others do prompting for a minimum required version.
(Not even NVAPI or AMD ADL that’d be later in the startup process.)

Unless it’s a UPlay thing. :slight_smile:

Just wanted to say that doing the dx9 and silent=true things still didn’t work for me. Using SKIF and the latest Steam version of Odyssey.