Disable Resolution Management

I was wondering whether there was a way to globally disable framebuffer/window resolution management in SpecialK so that the application always handles resizing and adjusting the framebuffer.

Reason I ask is that I tend to play at a few varieties of resolutions depending on where I’m currently playing my games (3440x1440 on my monitor, 4K when streaming or on my bedroom TV, 1080p on my projector) and it is a little annoying that to use SpecialK in conjunction, I have to edit the INI file or use the interface to adjust the resolution, adjust the ingame resolution, then restart the game to get it to fit.

Is there an option for that that I am missing?

Either click on the “Override resolution” row in the control panel, or edit the config file and remove the resolution or set it to 0x0.

See, I’ve tried setting it to 0x0 but even then if I go into the game and change the resolution, it’ll change the framebuffer resolution to 4K (for example) but it’ll still output into a 3440x1440 window, and doesn’t change till I restart. Was wondering whether there was a way I could avoid having to restart the application for those types of things to take effect.

That sounds like another issue entirely. What game is this? And can you upload the Special K logs from the game?

Min, max and override. If all of those are at 0x0 it shouldn’t try to alter anything.



Some of the bundled mods might have these pre-set to 3840x2160 from what I remember but once set back to 0x0 SpecialK shouldn’t try to override anything else.

What more.


Those two I think also prevents some window resolution overrides if enabled as part of limits for waitable swap chain values (As of version it’s either a 0 or 1 value here.) and flip model presentation override with flip discard.

EDIT: Flip model shouldn’t force a resolution override though just limit exclusive full-screen support and you can’t switch window state or resolution on the fly if I remember this correctly.